23

This question already has an answer here:

To make USB devices accessible to a guest OS under VirtualBox, one must

  i) install the appropriate extension pack 

 ii) navigate to 'Settings ----> USB' in the VirtualBox menu and

iii) tick 'Enable USB 2.0 (EHCI) Controller

 iv) add a `USB device filter` 

Step iv) requires selecting a USB device filter by clicking on a list of available USB devices which appears at the mouse-pointer position

  • when clicking on the 'Add new USB filter` icon on the right margin ( a USB icon with a green plus sign )
  • when pressing ALT+INS

    enter image description here

In either case one will see a list of USB device candidates currently attached to the host system.

enter image description here

These can then be selected and will appear permanently under the 'USB Device Filters' list of the USB menu.

enter image description here

This does not work under 14.04.

When attempting to add an attached device ( clicking on appropriate icon or pressing ALT+INS )

enter image description here

  • VirtualBox can not see any of the connected USB devices, resulting in a <no devices available> message.

  • Trying to enter the device details manually into a blankly created USB device filter does not work either.

  • Booting the guest OS ( Win 7 ), you are not able to see any 'removable drives'.

The obvious items were all checked:

  • VirtualBox installed from repository ( apt-get install ) App reports version 4.3.10

  • Appropriate VirtualBox extension pack ( 4.3.1r93733 ) successfully downloaded+installed from the Oracle site

As mentioned previously on the the same box with 12.04 installed everything works as it should and Win7 can see the removable drive as expected.

As a last resort various permutations of VM settings, USB sticks, e.t.c. were tried without achieving the desired result.

  • Has anyone encountered the same issue?
  • Has anyone encountered similar difficulties?
  • Has anyone been able to work around the problem? ( remember manual entry of device details into an empty filter entry has not worked )

Does anyone know if this is an issue

  • with VirtualBox?
  • with the current version of the VirtualBox extension pack?
  • or perhaps even with Trusty Tahr itself?

I have full USB functionality on my 14.04 host.

marked as duplicate by Seth Oct 8 '15 at 0:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

53

You probably have a permission issue. Add your user ID to group vboxusers with this command: sudo usermod -a -G vboxusers $USER, log off, log on and try again.

  • 1
    Yeap...that did it! Thanks for that! – darbehdar Jun 11 '14 at 12:05
  • That worked for me too on Ubuntu 14.04! – jhbsk Oct 19 '15 at 19:54
2

I tried all of the above to no avail. I then tried a right mouse click over the USB filter area and found a menu choice "Add filter from device". Voila! It worked.

1

I just spent last 6 hours trying to get my USB backup drive to work on my Ubuntu 14.04(host) with Win7Pro(guest). Fortunately, I found one article from Tyler Durden(see link below) which mentioned incompatibility between older version of VirtualBox 4.3.10(downloaded from Ubuntu Software Center) and VirtualBox Extension Pack 4.3.14(downloaded from VirtualBox.org).

After re-installing with the new version of VirtualBox, so far everything appears to be working fine, YMMV.

How to set up USB for Virtualbox?

protected by Community Aug 13 '15 at 9:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.