I've installed Ubuntu 14.04 and I'm experiencing a fuzzy/blurry screen and bad support for multiple screens.

I realized that Ubuntu installs nouveau as default, but I need to install nvidia drivers, so I tried this:

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
apt-get update
apt-get install nvidia-current
apt-get upgrade

Now that nvidia is installed, you need to blacklist the nouveau driver so it don’t pop out when you will reboot. Create or edit the following file:

nano /etc/modprobe.d/blacklist-nouveau.conf

…and add these lines at the end:

blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off

I checked via the software & updates if nvidia driver got installed successfully, and it says the driver installed is nvidia 304.117

I then tried to run:

lshw -c video | grep 'configuration'

and the result is that the driver is still nouveau:

configuration: driver=nouveau latency=0

So how do I install and use the nvidia drivers?

  • Added as an answer. Please upvote/accept so that others with your question can find it! – Elder Geek Jun 10 '14 at 19:47
  • 1
    Thank you for pointing out how Nouveau was causing blurry screen. I thought I was going blind and had even followed google's advise to delete all cache and history in misguided attempt to fix. Blacklisting Nouveau (and rebooting a couple of times) made my screen crystal clear again. – WinEunuuchs2Unix Sep 15 '16 at 3:58

Ubuntu 14.04 through 16.10

Please note that nouveau drivers manual removal is required only if you are going to install the proprietary nvidia drivers yourself. If this is not the case then directly install the required graphic drivers from System > Administration > Hardware drivers. It's the recommended and the most convenient way available.

We'll blacklist all the culprit modules, remove all the nvidia* packages and as an extra step we may have to update the initramfs disk because it could be configured to load the modules at startup.

  1. Blacklist the modules. Open the blacklist.conf file.

    sudo vim /etc/modprobe.d/blacklist.conf
    

    press i to enter insert mode and add the following modules in the file.

    # this one might not be required for x86 32 bit users.
    blacklist amd76x_edac 
    
    blacklist vga16fb
    blacklist nouveau
    blacklist rivafb
    blacklist nvidiafb
    blacklist rivatv
    

    Save the file and exit.

  2. Remove all the nvidia* packages

    sudo apt-get remove --purge nvidia-*
    
  3. Once you are done with the steps above, reboot, stop the display manager and try to install nvidia drivers.

    Press Ctrl+Alt+F1. Once you are in the text mode, stop the display manager. This will forcibly terminate all running applications, so you better save anything you're working on and close them yourself before completing this step. To stop the display manager, run one of these commands depending on your display manager (lightdm is default in vanilla Ubuntu, but older versions or systems with GNOME desktop may use gdm and on KDE/Kubuntu/Plasma it should be kdm:

Edit: To determine what the default display manager your Ubuntu system is using, issue the command cat /etc/X11/default-display-manager While this doesn't guarantee you anything, in many cases it will be the correct choice.

    sudo service lightdm stop

    sudo /etc/init.d/gdm stop

Now, run the driver package that you downloaded from Nvidia’s website. Edit: Replace the filename in the example below with the one you actually have.

    sudo ./NVIDIA-Linux-x86-260.19.44.run

Note: If you still get the error related to nouveau drivers then you are probably required to update the initramfs, which might be configured to load the nouveau drivers. Don't reboot or poweroff, run this command to update the initramfs disk.

sudo update-initramfs -u

Now reboot and repeat step 3. This time things should go smoothly.

  • Is there a way to do this during Ubuntu installation? I'm stuck on what appears to be an issue with the Nouveau drivers, see askubuntu.com/questions/507226/…. – Tyson Trautmann Aug 5 '14 at 21:45
  • 1
    Thank for his recipe. Worked for me in Ubuntu 14.04, just 2 notes: to stop X needed sudo service lightdm stop (instead of /etc/init.d/gdm stop) and needed one more reboot after update-initramfs. – tomasb Feb 1 '16 at 23:50
  • 1
    This worked to pass by the nouveau driverd on Ubuntu 16.04. – Manuel J. Diaz Aug 28 '16 at 1:45
  • 1
    This worked very nice on Ubuntu 16.10, great answer – Oscar Reyes Jan 10 '17 at 6:57
  • 1
    On xubuntu at least, you don't have to reboot to remove the noveau driver. After stopping the display manager modprobe -r nouveau unloads the noveau driver from the kernel. – gerardw Jul 25 '17 at 15:35

Manual removal of nouveau is not required anymore. If you install nvidia drivers from Additional Drivers on Ubuntu, the installation scripts will make sure that nouveau is blacklisted.

However, before you do anything you have to add graphics repo for nvidia drivers:

sudo apt-add-repository ppa:graphics-drivers/ppa
sudo apt-get update

I suggest you have a look at nvidia website for the drivers your card supports and install those from the Additional Drivers tool on Ubuntu.

Insert

blacklist nouveau
blacklist lbm-nouveau
options nouveau modeset=0
alias nouveau off
alias lbm-nouveau off

into

etc/modprobe.d/blacklist.conf

and reboot, before installing the NVidia driver. Worked for me on Ubuntu 16.04 LTS.

  • Its good to have 16.04 instructions because the questions and answers are about 14.04. Can you put '16.04 How To" at the beginning in Heading format? +1 – WinEunuuchs2Unix Sep 14 '16 at 22:09
  • This worked for me on 16.04 but I had to run sudo update-initramfs -u before rebooting and attempting the .run file installation again. I had to do it this way because Ubuntu broke their apt package. – jchook Jan 15 at 17:19

Blacklisting nouveau as mentioned in nvidia's documentation doesn't work. We don't need to blacklist it. Just install the nvidia drivers using apt. You just need to login to tty by pressing ctrl+alt+f1 and stop the lightdm service and then type

sudo apt-add-repository ppa:graphics-drivers/ppa 
sudo apt install nvidia-384 _(or whatever version compatible with your GPU)_  

then restart

protected by Community Apr 18 at 14:26

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.