For some unknown reason, my Unity dash doesn't show recent applications. I am guessing it could be related to the fact that I have a newer version of zeitgeist than the standard repo provides (I use a ppa).

That is the only unusual detail I can think of. What can I do to get back recent applications in the dash?

  • Do you have zeitgeist from this Zeitgeist PPA? – Manish Sinha Jun 15 '11 at 13:19
  • @Manish as far as I remember. – RolandiXor Jun 15 '11 at 14:00
  • @Manish could that be the reason? – RolandiXor Jun 23 '11 at 16:09
  • taylor Still need to investigate. It would be great if someone from Unity team could look into this. I will try to find out someone. – Manish Sinha Jun 28 '11 at 9:13

There was a similar problem reported here

The solution was to reinstall unity-lens-applications and unity-lens-files packages and the Dash magically works.

Both these packages were formely named unity-place-applications and unity-place-files

We are looking into it. Probably some packaging issue.

  • I had marked this as solved, but after testing I still have the problem :'(. I restarted unity it still won't show any recent applications. Recent files work just fine. – RolandiXor Jun 28 '11 at 19:19
  • It doesn't show just "Recent Applications" or no Applications at all? – Manish Sinha Jun 29 '11 at 7:43
  • Only recent applications don't show. – RolandiXor Jun 29 '11 at 13:58
  • This means this is an issue with Recent Applications with Unity Dash. Since recently used applications does indeed use Zeitgeist, so I guess this needs to be investigated. If this issue is too much troubling, then you can try to downgrade the zeitgeist version by opening in Synaptic and do a "Force version" to the version which comes with Ubuntu. By the time I can find a solution – Manish Sinha Jun 29 '11 at 14:37
  • I'll just leave it as is. I have Synapse, so I am not too highly bothered, and I can use my system as a test bed for providing info toward fixing it :). – RolandiXor Jun 29 '11 at 15:27

In my case none of the solutions above worked.

The solution I found to work:

sudo rm -rf ~/.local/share/zeitgeist

Then close your session and login again, and dash worked again.


for recent apps to show in dash in ubuntu 16.04 turning on record file and application usage (in security & privacy) worked for me

snap shot - record file and application

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.