0

I want to build my application on Ubuntu. The last versions have been tested and programmed under Windows, because it is a multiplatform application. Sadly, under Ubuntu the systray icon did not work as I tried to compile on Ubuntu (the icon appeared next to the launcher). The icon is a must-have for my application.

I've heard this comes from the version of Qt, since 5.0 the SniQt that makes an AppIndicator would not work any more. So I figured, if I compile my application with Qt 4.x, it must work.

But how do I install this "old" version?

1

Both QT5 and QT4 are in main Ubuntu repository for 14.04

You can simply install QT4 as

sudo apt-get install qt4-default libqt4-dev qtchooser qt4-designer
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.