0

I have a problem installing a php extension (Phalcon framework) due to having upgraded from php 5.3 to 5.4 some time ago.

I upgraded using ondrej-php5-precise repository. Everything is working ok and if I run phpinfo I get that the version is

from cli:

PHP 5.4.17-1~precise+1 (cli) (built: Jul 17 2013 18:14:06)

from web:

PHP Version 5.4.17-1~precise+1

But if I run php-config5 --version I get 5.3.10-1ubuntu3.11

And now when I try to install phalcon it compiles it for php5.3 instead of php5.4.

I've read on the forums that I need to use the right phpize for 5.4 when building it. But I have two files phpize and phpize5 (same for php-config and php-config5) and both point to php5.3 version

Stev

0

Either you haven't upgraded php5-dev package - try searching for a package: dpkg -S $(which php-config5) and upgrade the package using ppa to match the php version.

The other most probable cause is some local forgotten installation of php5.3 - look in /usr/local

  • I've upgraded php5-dev package and that brought everything to php5.5.12 and the installation of phalcon went smoothly. – Stev Jun 10 '14 at 10:39

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.