6

I have Ubuntu installed on VMware player.

After installing the last updates the screen went like this image: enter image description here

As you see I have not real second Menu(it is not clickable)

Why did this happen and how to fix?

1
  • I can't add an answer since the question has been protected, but VMWare has an explanation and several possible solutions here: communities.vmware.com/message/2398873#2398873 Just changing the VM Hardware version worked for me - no need to downgrade anything. Commented Nov 11, 2014 at 21:08

5 Answers 5

3

I used my VM previous snapshot to reproduce the problem.

Previous kernel: 3.2.0-63. VM running ok.

1) I applied all updates (including openssl) but NOT the kernel. After rebooting, the VM screen is OK.

2) I updated again (only the kernel packages, version 3.2.0-64 were pending: complete kernel, headers and kernel image) and rebooted: split / doubled screen shows up!

3) I ran vmware-config-tools.pl in other to generate modules for the new kernel and rebooted: the split screen persists. Not solved.

4) also tried a full VM power off / power on: the problem persists.

It seems to be definitely a kernel 3.2.0-64 - related issue.

Suggestion: apply all updates (the openssl update is critical), but skip the kernel packages for now, until we get a fix from VMware or the Ubuntu team.

(AND: ALWAYS create a snapshot before you update anything !!)


See also these threads:

https://communities.vmware.com/message/2388587#2388587

https://communities.vmware.com/thread/481038

In summary: if you don't have a previous snapshot, either enable the grub menu on boot and choose a previous kernel (e.g. 3.2.0-63) or: using the package manager, uninstall the kernel 3.2.0-64 and RE-INSTALL the previous kernel (this will take care of grub and boot configs).

Let's wait for a fix. And don't update the kernel for now.

3

Confirmed - Same issue with VMWare Workstation 10.0.2 with Ubuntu 12.04 LTS.

Solved with:

sudo apt-get remove 3.2.0-64
sudo update-grub
sudo reboot
2

Try the answer described here :

Open System Settings > Displays. In the Displays window, you will see an Unknown monitor. Click it and disable it.

0
2

Since the 14.04LTS question was marked as a duplicate of this one, the solution for 14.04LTS is very similar.

To fix this issue on 14.04LTS I used the following:

 sudo apt-get remove 3.13.0-29-generic
 sudo update-grub
 sudo shutdown -r now

This reverted the kernel to 3.13.0-27-generic which does not exhibit the issue.

1

I have 14.04LTS on vmplayer, and for me help removing 3.13.0-30-generic

sudo apt-get remove 3.13.0-30-generic
sudo update-grub
sudo shutdown -r now

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .