0

How does one configure Radeon video cards when using the open source Radeon driver - power profile, vsync, etc?

Why I try the widely documented solution (against overheating) that worked for me under LMDE (confirmed with kernels up to 3.12.6), I get the following error:

$ sudo cat /sys/class/drm/card0/device/power_profile
default
$ sudo sh -c "echo mid > /sys/class/drm/card0/device/power_profile"
sh: echo: I/O error
Exit 1

And when I try suggestions from Arch's ATI wiki my modifications are simply ignored:

$ sudo cat /sys/class/drm/card0/device/power_dpm_force_performance_level
auto
$ sudo sh -c "echo high> /sys/class/drm/card0/device/power_dpm_force_performance_level"
$ sudo cat /sys/class/drm/card0/device/power_dpm_force_performance_level
auto

Is this something Ubuntu specific, or something introduced with the 3.13 version of the Radeon driver? I'm encountering this on 2 laptops, one with a Radeon HD6290 (integrated GPU), the other with a discrete RV710 card. The RV710 needs a specific power setting to prevent overheating under LMDE, fortunately it doesn't seem to overheat with the Ubuntu default setting.

1

The change you noticed is not Ubuntu specific, it is due to runtime power management now being enabled by default in the Linux kernel. For most users this is a good thing - it means that the power of the GPU can adapt to runtime use, instead of being fixed at whatever the BIOS set it to. To revert to the previous behaviour, set the kernel parameter radeon.runpm=0.

The video card should not require any manual settings to prevent overheating. If you find that it does, then it may be a hardware issue (eg. fan needs cleaning). If you think the problem is software (works fine in another OS, or with proprietary driver) then report a bug on the mailing list, IRC channel or bug tracker at Xorg radeon.

| improve this answer | |
  • The overheating issue is with an HP G62 (model a55sf or something like that). It doesn't happen with the factory Win7 install, nor with the proprietary driver ("fglrx legacy", which is becoming hard to find in distros). I'm not the only one having noticed this, so yeah, I'm quite confident it's a software problem. I'll see if I can stress-test the RV710 board a bit more with the newer driver. Unless you feel otherwise, I think it's not very useful to file a bug for a driver in the 3.12 kernel? – RJVB Jun 9 '14 at 12:17
  • 1
    Not really. 3.15 is out now. 3.12 was 7 months ago. The Linux kernel moves fast these days. When it comes to Radeon drivers, I think you are much more likely to get a response from the Xorg radeon bug tracker or mailing list than anywhere else. – bain Jun 9 '14 at 13:01
  • As I thought.... Overheating is not the only reason I started looking for configuration options. Since a little while I'm noticing overly visible shearing when watching fullscreen streaming Flash video. Happens in Chrome and Firefox, so it's not due to a recent pepper Flash update. Hardware acceleration is on, in Flash, and in all chrome://flags options. Any thoughts on this issue? – RJVB Jun 10 '14 at 16:22
  • There are several variables that contribute to tearing: application, render path, driver. All have to support vsync and be configured properly to prevent tearing. In your case Fullscreen video from Pepper Flash is tearing may be relevant. Otherwise I would suggest asking on the radeon mailing list to find out exactly what vsync configurations the driver supports. – bain Jun 10 '14 at 17:27
0

After more testing, it seems it was mostly the Pepper Flash plugin that was the culprit. With all Chrome's hardware acceleration settings on, I now get very good streaming video playback with the radeon driver, while the proprietary driver still tears, The latter tears even when using Adobe's own Flash player, which is from the same era as the legacy fglrx driver, so something must have changed on the content level too, maybe forcing software rendering which the modern Radeon driver does better (if not only because I built it, with settings optimised for the local CPU)?

Anyway, I'll be moving the G62's install to Kubuntu with the Radeon driver as it performs better on the things that matter and no longer shows the overheating issues.

Now, if only I could find a way to prevent the screensaver/locker to kick in while watching fullscreen streaming video (even with the mouse cursor in a "don't lock" hot-corner) ... but that's a different topic :)

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.