62

In XFCE4 desktop environments, alt+scroll wheel zooms my entire desktop. I'm finding this very annoying because sometimes I flick the scroll wheel to go to the top of a document then press the alt key for a some unrelated keyboard shortcut and find myself zoomed in so far I can't see anything at all.

Is there any way to disable this feature?

1
  • To get out of the zoomed desktop, just hold ALT and use your mouse wheel to scroll in the opposite direction
    – smac89
    Jan 14, 2021 at 7:25

7 Answers 7

82

There is an easy way, without losing the moving windows feature.

  1. Open Settings Editor
  2. Go to Channel xfwm4
  3. Disable Property zoom_desktop
5
  • This is the only acceptable answer. Unfortunately, the property doesn't seem available yet in Xfce 4.10. Oct 28, 2015 at 20:31
  • 4
    Just to be clear, since I didnt notice, 'settings editor' != 'settings'. you have to choose 'settings editor' inside 'settings', and then this magic works :-) May 1, 2016 at 11:22
  • Every time I setup a new Laptop with XFCE I come back here :) Apr 16, 2021 at 6:14
  • Thank you! That zoom_desktop thing is such a PIA! Apr 21, 2021 at 19:52
  • If you still want to be able to use desktop zooming, check out my answer.
    – jarno
    Apr 22, 2021 at 5:19
15

Here is how disable this feature from the command line:

xfconf-query --set false --channel xfwm4 --property /general/zoom_desktop

If you get this message:

Property "/general/zoom_desktop" does not exist on channel "xfwm4".
If a new property should be created, use the --create option.

then run this command instead:

xfconf-query --create --type bool --set false --channel xfwm4 --property /general/zoom_desktop
1
  • 1
    as GUI seem to change a lot this is the answer that works in 2020
    – U.V.
    Dec 6, 2020 at 16:03
14

To activate or deactivate, there is also another option in Window Manager Tweaks. Under Compositor, the option to enable or disable display compositing will also enable or disable desktop zoom.

1
  • 1
    Thanks! Because Compositor was disabled, I was unable to find/utilize this feature. Jul 12, 2016 at 18:08
1

To disable this setting from the gui now in xfce4, do the following:

  1. Click your Application launcher icon (typically the top-left corner of the screen) & select "Run Program..." Alternatively, use the keyboard shortcut "Win-R"
  2. In the "Application Finder" window that appears, type: xfwm4-tweaks-settings and click "Launch"
  3. Click "Compositor" tab
  4. Untick 'Zoom desktop with mouse wheel'
  5. Click "Close"
0

Translation:

Opens the System Setup window, then enter the administrator settings window and section accessibility this box that enables or disables this function.


Abre la ventana de configuración del sistema, luego entra al gestor de ajustes de ventana y en la sección accesibilidad esta la casilla que habilita o deshabilita esta función. enter image description here

2
  • That doesn't look like what tctimmeh was asking at all, and you're posting several years later than the correct solution. Did you mean to post that here? To be clear, the magnifier is an "accessibility" option, but zooming in on the entire desktop is not. I'm on a new installation of Xubuntu, and accessibility has never been enabled and would require restarting the computer, but alt+scroll desktop zooming has been there from the beginning.
    – John P
    Aug 7, 2017 at 13:10
  • That doesn't answer this question, but helped me to solve another probem.
    – vstepaniuk
    Nov 9, 2020 at 10:16
0

In manjaro I did this on the settings editor

Here you have to uncheck zoom_desktop value:

enter image description here

0

If you still want to be able to use desktop zooming, I have a couple of tricks by which you may be able to prevent accidental desktop zooming.

You can control which key is bind to desktop zooming at Window Manager Tweaks > Accessibility > Key used to grab and move windows. You can even select "none" so that it effectively disables desktop zooming, but that will disable the mentioned window grabbing function, too. Someone has requested ability to configure a distinct key for the zooming feature here.

I made a utility that you can run in background. It blocks subsequent scrolling events (and other events of the given pointer device), while you press a modifier key after starting scrolling in X11. That is especially useful, if you device has inertial scrolling function that you can not or do not want to disable. See my answer for another question for more details.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.