3

I am new to Ubuntu.

I got the following lines after an interrupted apt-get install.

Running depmod.
update-initramfs: deferring update (hook will be called later)
Examining /etc/kernel/postinst.d.
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.13.0-29-generic /boot/vmlinuz-3.13.0-29-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.13.0-29-generic /boot/vmlinuz-3.13.0-29-generic
update-initramfs: Generating /boot/initrd.img-3.13.0-29-generic
run-parts: executing /etc/kernel/postinst.d/pm-utils 3.13.0-29-generic /boot/vmlinuz-3.13.0-29-generic
run-parts: executing /etc/kernel/postinst.d/update-notifier 3.13.0-29-generic /boot/vmlinuz-3.13.0-29-generic
run-parts: executing /etc/kernel/postinst.d/zz-update-grub 3.13.0-29-generic /boot/vmlinuz-3.13.0-29-generic
/usr/sbin/grub-mkconfig: 14: /etc/default/grub: nouveau.modeset=0: not found
run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 127
Failed to process /etc/kernel/postinst.d at /var/lib/dpkg/info/linux-image-3.13.0-29-generic.postinst line 1025.
No apport report written because the error message indicates its a followup error from a previous failure.
                                                                                                          No apport report written because MaxReports is reached already
                        No apport report written because MaxReports is reached already
                                                                                      No apport report written because MaxReports is reached already
    No apport report written because MaxReports is reached already
                                                                  No apport report written because MaxReports is reached already
                                                                                                                                No apport report written because MaxReports is reached already
                                              No apport report written because MaxReports is reached already
                                                                                                            dpkg: error processing package linux-image-3.13.0-29-generic (--configure):
 subprocess installed post-installation script returned error exit status 2
dpkg: dependency problems prevent configuration of linux-image-extra-3.13.0-29-generic:
 linux-image-extra-3.13.0-29-generic depends on linux-image-3.13.0-29-generic; however:
  Package linux-image-3.13.0-29-generic is not configured yet.

dpkg: error processing package linux-image-extra-3.13.0-29-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-generic:
 linux-image-generic depends on linux-image-3.13.0-29-generic; however:
  Package linux-image-3.13.0-29-generic is not configured yet.
 linux-image-generic depends on linux-image-extra-3.13.0-29-generic; however:
  Package linux-image-extra-3.13.0-29-generic is not configured yet.

dpkg: error processing package linux-image-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-generic:
 linux-generic depends on linux-image-generic (= 3.13.0.29.35); however:
  Package linux-image-generic is not configured yet.

dpkg: error processing package linux-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-image-extra-3.13.0-27-generic:
 linux-image-extra-3.13.0-27-generic depends on linux-image-3.13.0-27-generic; however:
  Package linux-image-3.13.0-27-generic is not configured yet.

dpkg: error processing package linux-image-extra-3.13.0-27-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-signed-image-3.13.0-29-generic:
 linux-signed-image-3.13.0-29-generic depends on linux-image-3.13.0-29-generic (= 3.13.0-29.53); however:
  Package linux-image-3.13.0-29-generic is not configured yet.
 linux-signed-image-3.13.0-29-generic depends on linux-image-extra-3.13.0-29-generic (= 3.13.0-29.53); however:
  Package linux-image-extra-3.13.0-29-generic is not configured yet.

dpkg: error processing package linux-signed-image-3.13.0-29-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-signed-image-generic:
 linux-signed-image-generic depends on linux-signed-image-3.13.0-29-generic; however:
  Package linux-signed-image-3.13.0-29-generic is not configured yet.

dpkg: error processing package linux-signed-image-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-signed-generic:
 linux-signed-generic depends on linux-signed-image-generic (= 3.13.0.29.35); however:
  Package linux-signed-image-generic is not configured yet.

dpkg: error processing package linux-signed-generic (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of linux-signed-image-3.13.0-27-generic:
 linux-signed-image-3.13.0-27-generic depends on linux-image-3.13.0-27-generic (= 3.13.0-27.50); however:
  Package linux-image-3.13.0-27-generic is not configured yet.
 linux-signed-image-3.13.0-27-generic depends on linux-image-extra-3.13.0-27-generic (= 3.13.0-27.50); however:
  Package linux-image-extra-3.13.0-27-generic is not configured yet.

dpkg: error processing package linux-signed-image-3.13.0-27-generic (--configure):
 dependency problems - leaving unconfigured
Setting up libxkbcommon-x11-0:amd64 (0.4.1-0ubuntu1) ...
Setting up libqt5gui5:amd64 (5.2.1+dfsg-1ubuntu14.2) ...
Processing triggers for libc-bin (2.19-0ubuntu6) ...
Errors were encountered while processing:
 linux-image-3.13.0-27-generic
 linux-image-3.13.0-29-generic
 linux-image-extra-3.13.0-29-generic
 linux-image-generic
 linux-generic
 linux-image-extra-3.13.0-27-generic
 linux-signed-image-3.13.0-29-generic
 linux-signed-image-generic
 linux-signed-generic
 linux-signed-image-3.13.0-27-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)
  • Can you post the contents of your /etc/default/grub – bain Jun 8 '14 at 23:48
  • Strange stuff related to "linux-image-3.13.0-29-generic", 3.13.0-24-generic works for me. – Hannu Jun 13 '14 at 16:35
2

Try running sudo dpkg --configure --pending

1

Try running sudo apt-get install -f

1

I installed defaul video drivers for my AMD Radion HD 7610M and the conflicts was settled. Never buy a laptop with AMD video card, disgusting driver support under linux.

0

/etc/default/grub: nouveau.modeset=0: not found

This line indicates that you have somehow corrupted /etc/default/grub and now it is trying to execute as a command nouveau.modeset= instead of interpreting it as part of the kernel command line.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.