3

Yesterday I switched back from Linux Mint to Ubuntu 14.04 and after installation I faced the following problem: When I login with my user account Unity isn't loading. I can see no desktop elements - all I have are the desktop icons in some kind of GNOME-scheme. But when I login as a guest on the guest account, Unity is working fine. I read and tried alot yesterday as Ubuntu 14.04 seems to have plenty of issues with lightdm, compiz, ... but nothing worked for me. I have two asumptions:

  1. Because the guest account works, it seems to be an user specific problem.
  2. Because the guest account works, there seems so be no problem with graphic driver etc.

To 1: Are there user specific configurations? Maybe in xorg.conf? Any other explanations why the guest account works fine and my user account does not?

To 2: I have a Nvidia GEFORCE 520M running. I tried the nvidia-driver, but then no desktop appeared, neither in guest account nor in my user account. So I removed them.

I tried so many things yesterday, so that I absolutely lost track on more possible solutions. Anyone an idea?

1
  • Do you remember changing to unity 2d or something?
    – Venkatesh
    Jun 8, 2014 at 13:20

4 Answers 4

3

Open the terminal using (ctrl+alt+T), and try to reset compiz and unity by:

sudo apt-get install dconf-tools    
dconf reset -f /org/compiz/       
unity-reset
setsid unity

If you are still facing it, then open terminal again and reinstall desktop and unity

sudo apt-get update
sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install unity
3
  • BTW I hated unity on 14.04 x86_64 because compiz was always crashing and switched back to Gnome! Still evaluating the performance so can't recommend to switch to Gnome atm.
    – OdinRW
    Jun 8, 2014 at 12:35
  • 1
    I'm going to upvote this answer, because it got me unstuck enough so that I could get back to work, but please note all of your settings get reset. So you're going to lose all those keyboard shortcuts and whatnot that you might have spent a significant time tweaking. Editing this answer to include instructions for backup would be greatly appreciated
    – Seanny123
    Jun 23, 2014 at 19:13
  • dconf reset -f /org/compiz/ did the trick for me. (Had to additionally export DISPLAY=:0 and set the DBUS_SESSION_BUS_ADDRESS variable as outlined in askubuntu.com/questions/457016/…, on a separate tty (Ctrl+Alt+F1).) Nov 27, 2014 at 1:15
1

It's probably something in your $HOME. You may want to temporarily move whatever contents you wish to save to somewhere else, remove the remaining files in $HOME, and copy the files in /etc/skel to $HOME. Doing so would eliminate your personal settings, but since you just switched from Mint I'm assuming it doesn't matter.

2
  • Yep, cleaning out the entire home directory worked for me. Unfortunate, but nothing else I tried worked. So I know it was something to do with a conf file most likely, although I have no idea what, and likely never will.
    – Alex G
    May 16, 2016 at 0:01
  • 2
    For anyone else who has the problem @AlexG had: I tried everything as well, and like Alex, could only fix the issue by deleting everything in $HOME. I finally found the source of the problem: when I was copying over the files, I was doing so as root, and as a result, all of the files in $HOME had root as their user and group. When I chown'ed the user and group of all of the files/directories to the user account, it worked.
    – Amin
    Sep 5, 2016 at 12:07
1

This is one of those catch 22 situations where you need to fix a problem but you can't get the screens that would fix the problem to display. On my machine everything worked in the guest account, but there was nothing I could do there that would allow changes to be permanent. I could not get to much of anything on the user screen (after all, that was the problem) and I am not really proficient in a command line interface. The (at least partially workable solution:

Log in to your regular account. Unity doesn't work, but a right click will bring up the window to allow me to change the background. (not that it will fix anything!) But it will allow you to open "All Settings". From there you can open "User Accounts", unlock it, and set up a "New User" account with the appropriate privileges. On my machine, when nothing else worked for my normal login, the new user worked perfectly! You can then either change the settings on the new user account to fix the problem or simply change the settings in the new user account to suit your needs and keep using it! Problem solved! (sort of.... at least it is quick and easy and you can get back to work!)

0

For what it is worth... Same problem. Spent some time to find minimum to fix. Deleted the home/.gconf/desktop/gnome folder. Logged back in. All good.

Lenovo y70 touch. 15.04 64bit.

1
  • I'm sorry, but this is a bad quality answer. To remove the negative reputation points, edit your answer, improve it, and drop a note so that I can review my assessment of your answer. Alternatively, [delete] it altogether and the negative reputation points will be reversed automatically by the system. (I do this too for answers that give me negative reputation points) ;-)
    – Fabby
    Sep 4, 2015 at 19:57

You must log in to answer this question.