My laptop is Toshiba M840. When I suspend, my laptop auto resumes immediately. I used acpitool to check what devices made my computer waking up. After I disable the XHC, my computer suspends properly. But after restart, the XHC was enabled. How can I disable it forever?

marked as duplicate by Anwar, Zanna, TheWanderer, Eric Carvalho, WinEunuuchs2Unix Oct 27 '16 at 23:54

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

You can try to disable it with a Upstart script every startup automatically:

Create a file etc/init/disable-XHC.conf

Content:

start on started dbus
stop on stopping dbus

script
   sudo -u root sh -c "echo 'XHC' > /proc/acpi/wakeup"
end script

Not the answer you're looking for? Browse other questions tagged or ask your own question.