2

I've set up linux-crashdump to debug issues with lockups by following the instructions here: https://help.ubuntu.com/12.04/serverguide/kernel-crash-dump.html

However, when I try to test using: echo c > /proc/sysrq-trigger, my screen just goes blank. This happens if I'm in X or even if I'm in VT1. Does it have to do with the fact that my VT is in framebuffer mode? When I try the crash I have no idea if the dump is working or if my system is just frozen.

When a crash does occur, I'd like to have some indication that something is still going on. Is there a way to configure kcrash to switch to a non-framebuffer VT when dumping? Or is this technically impossible?

2

I figured out how to do this. Basically you need to make sure kexec loads the vga16fb.ko module, which allows it to work in framebuffer mode. This can be done by adding --module=vga16fb.ko to the KDUMP_KEXEC_ARGS setting in /etc/default/kdump-tools. For example, mine looks like this:

KDUMP_KEXEC_ARGS="--elf64-core-headers --reset-vga --module=vga16fb.ko"

The --reset-vga parameter was there from my first attempt. It didn't originally work but I left it in there.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.