2

I'm assuming that at some point I may have mistakenly assigned the wrong driver to my wireless card while attempting to boost signal strength. Is there any commands that would allow me to reclaim my wifi card and set the correct drives?

It took a minute to find it, but I think this is the command that did it.

sudo apt-get install firmwire-b43-installer b43-fwcutter

which did not install, or this one,

sudo apt-get remove bcmwl-kernel-source

In the windows driver installer the files were netathr.inf and netathrx.inf. The program marked them with an error of which I can't remember.

I have re-installed bcmwl-kernel-source and nothing. I don't even know if it is related to my problem.

My card is

Network controller: Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01).

I have Ubuntu 14.04 LTS in which I have just upgraded to in hopes that it would fix this same problem I experienced in 12.04 LTS.

I'm currently running wifi from a usb controller, but I need the internal card to work because this wifi usb controller is not mine, nor is it small. It is very large for what it is and I would much rather have my laptop work like it is supposed to.

sudo lshw -C network

  *-network UNCLAIMED
       description: Network controller
       product: AR9285 Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:07:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f0100000-f010ffff

In case more info is needed.

rfkill list all

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

nmcli nm

RUNNING         STATE           WIFI-HARDWARE   WIFI       WWAN-HARDWARE   WWAN      
running         connected       enabled         enabled    enabled         enabled

iwconfig without usb controller

eth0      no wireless extensions.

lo        no wireless extensions.

What can I do to resolve this issue?

I have entered the following code with no result.

sudo apt-get install linux-firmware-nonfree wicd wicd-gtk wicd-daemon wicd-cli wicd-curses
3
  • you installed what driver from where? How did you install the driver?
    – fossfreedom
    Jun 10, 2014 at 7:15
  • "some point I have mistakenly assigned the wrong driver to my wireless card " ... your words. How did you assign the wrong driver? Add the details to your question. What windows driver did you install from the software center? What broadcomm package did you install?
    – fossfreedom
    Jun 10, 2014 at 7:26
  • Hey - no worries. +1 for a good answer.
    – fossfreedom
    Jun 10, 2014 at 9:24

1 Answer 1

5

I looked all over and I found my answer.

The answer was at the bottom of this page on Ubuntu Forums from "praseodym"

Deactivate the hardware encryption of the driver:

echo "options ath9k nohwcrypt=1" | sudo tee -a /etc/modprobe.d/ath9k.conf
sudo modprobe -rfv ath9k
sudo modprobe -v ath9k

I ran sudo lshw -C network and found that the "UNCLAIMED" marking next to my wifi card was gone and I could connect again. Thank you praseodym, wherever you are.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.