9

I opened my laptop today to find that my arrow keys, excluding the left arrow, and Delete key are not functioning correctly. The down arrow brings up the notification that the trackpad was disabled, the delete key brings up the notification that the trackpad was enabled, and the up and right arrows don't seem to do anything.

I'm running Ubuntu 14.04, I have an Acer laptop, and the keyboard model is set to Generic 105 key (Intl) PC. The keyboard language is set to English(US). I tried changing the model to a few different ones, but it didn't solve the problem. I noticed that a lot of people had this problem in the past, but I couldn't find a solution for myself. If you experienced this problem recently, how did you solve it? Or do you have any ideas on how I may fix it.

Also, I have Ubuntu installed as my operating system and am not using a VM.

3
  • I found a solution. I restarted my computer a few times but it never solved the problem. Then I restarted and hit F12 to bring up the menu to select which disk to boot from. I didn't make any changes and exited. Then I logged in to Ubuntu and my keyboard problem is fixed. This also fixed the problem of my keyboard being nonfunctional in GRUB.
    – deelawn
    Jun 8 '14 at 0:37
  • 1
    In my case, only Delete key is not working. All other keys are working properly. When I press Delete key, nothing occurs. Restart did not solved my problem. Feb 10 '15 at 22:23
  • @woodchip I just wanted you to know that after nearly a year, I finally tried this, and it worked for me too. There is clearly a bug somewhere.
    – Bill Sempf
    Aug 21 '15 at 20:47
8

I am an Acer user and have the same problem with you. I have already tried your suggestion, but the problem still occured. I have another helpful solution.

Type sudo dpkg-reconfigure keyboard-configuration into a terminal, then select Acer laptop as the keyboard model, then restart your laptop.

Reference: Delete and arrow keys not working

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.