I'm having a hard time fixing the ACPI subsystem of an HP laptop (Pavilion DV6-6008el, Ubuntu Natty 64-bit).

I can boot only if acpi=off is specified as kernel parameter in grub, otherwise blank screen and system hanging. Both blank screen and ACPI disabled are not acceptable. There is another similar question by me on Ask Ubuntu with other details.

I was able to find good docs about how to debug ACPI; particularly useful is this technique: if decompiling and recompiling a DSDT table the compiler gives an error, well... the table is broken and this could be the reason for the boot failure. Next step is fix the code, compile and override the system DSDT with the fixed one (recompiling the kernel or building the custom DSDT into an initrd). This is the procedure:

# apt-get install acpidump
# dump a system's ACPI table with DSTD signature to an ASCII file
sudo acpidump -t DSDT > dump

# convert ASCII acpidump output to raw binary table. Creates DSDT.dat, binary.
acpixtract dump

# apt-get install iasl
# disassemble AML to ASL, creates DSDT.dsl
# (AML: ACPI Machine Language, binary. ASL: ACPI Source Language, source)
iasl -d DSDT.dat

# recompile AML in assembler (-ta) or C (-tc) hex table. -vr disables remarks.
iasl -vr -tc DSDT.dsl

Oops, iasl intel compiler complains:

DSDT.dsl    37:     External (\TNOT)
Error    4057 -                    ^ Name already exists in scope (\TNOT)

DSDT.dsl 11050:     Method (PAPR, 0, NotSerialized)
Warning  1088 -                ^ Not all control paths return a value (PAPR)

DSDT.dsl 12566:     Method (_CRS, 0, NotSerialized)
Warning  1088 -                ^ Not all control paths return a value (_CRS)

DSDT.dsl 12566:     Method (_CRS, 0, NotSerialized)
Warning  1081 -                ^ Reserved method must return a value
                                 (Buffer required for _CRS)

ASL Input:  DSDT.dsl - 12748 lines, 424447 bytes, 5910 keywords
Compilation complete. 1 Errors, 3 Warnings, 8 Remarks, 20 Optimizations

Here is the full table source (36kb).

Any help to fix the issue, error and warnings, is greatly appreciated. Many thanks.

Useful resources

  • The source is not accessible (it requires some password I didn't have). On the surface it looks like there is a superfluous External definition on line 37, which you could try to remove. – taneli Aug 1 '11 at 18:47
  • Should it be moved to unix.stackexchange.com if no one is able to answer it? – Manish Sinha Aug 10 '11 at 8:25

You could try installing the fglrx drivers and tweaking the acpi options with aticonfig. Here is the link to the unofficial AMD wiki http://wiki.cchtml.com/index.php/Main_Page. It has helped me a lot. Please let me know if this helps. Thanks

  • There is another problem here, aticonfig says "No supported adapters detected". Though, thanks for the input. – Paolo Sep 20 '11 at 22:11

I try to do that myself.

I find the Gentoo Wiki very useful: ACPI/Fix common problems.

It's not directly applicable to Ubuntu, but almost.

The only difference I noticed so far is, when you install "iasl".


echo "sys-power/iasl ~x86" >> /etc/portage/package.keywords; emerge -av iasl


sudo apt-get install iasl

You could do a sudo modprobe fglrx then if it gives the same error then you might have to reboot. Please let me know if this helps. Thanks

  • No way to fix, I keep getting the same error. My card (ATI Radeon 6470M) is not supported. – Paolo Sep 21 '11 at 0:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.