For some reason, I've got some graphical issues sometimes. Mostly with AbiWord, LibreOffice (and OpenOffice.org), and Wine applications. I've added some screenshots below t oclarify a bit. This is not a problem that recently popped up. As a matter of fact, I've always had it since Ubuntu 8.10, and there never came an update to fix it. I'm currently using Linux Mint 10 (based upon Ubuntu 10.10), but as I already said, that doesn't really say much as I'va also had this problem with Linux Mint 8, Ubuntu 8.10, Ubuntu 9.04, Ubuntu 9.10 and Ubuntu 10.04. It was never a big problem, as I rarely used any text processing programs. But recently, I'm starting to use them more and more, and it's really annoying being unable to work because of this problem. When I first open an application, everything looks normal, then after a while (when I highlight, click, ... an item) they'll suddenly screw up. This also happens when I move or resize the window. Sometimes when this happens, I can just minimize the window, and when i restore it, sometimes it will be gone (for a few seconds at least) or it will have changed positions. I'm using the nvidia-current graphics card driver. But I have also always had this problem on my old computer, wich used... I think nvidia-96.

Screenshots LibreOffice Writer LibreOffice Writer LibreOffice Writer LibreOffice Writer Photoshop (Wine) (I've done the blur myself, so that's not the issue, the problem is that blue crap) LibreOffice Writer

  • What video card are you using? – bgvaughan Jun 12 '11 at 21:41
  • @bgvaughan NVidia Quadro NVS 110M – RobinJ Jun 13 '11 at 8:12
  • What theme are you using? I've had similar issues when I used dark themes – Dirk Hartzer Waldeck Jun 13 '11 at 14:00
  • Mix of Shiki-Wise and Mint-X-Metal. – RobinJ Jun 13 '11 at 15:55
  • Do you have the same trouble if you switch to the Ambiance or Radiance themes? – bgvaughan Jun 13 '11 at 19:40

It's a known bug in the nvidia drivers. Unfortunately, since you're using proprietary drivers, there is no way of getting this bug fixed except by maybe complaining on nvnews.net (where some nvidia reps hang out).

So the solution is to use the workaround listed in the bug report, or to switch to the free drivers.

And next time you're buying graphics hardware, remember nvidia's buggy drivers.. :-P

  • It came with this laptop. And I experienced that ATI's drivers can be far more buggy than NVIDIA's. As far as I know I'm am using the free driver.... (the one jockey recommended me). Anyway, I'll take a look at the workaround and see if it works. – RobinJ Jun 18 '11 at 15:42
  • Jockey only recommends non-free drivers. And AMD and Intel both actively develop Free drivers :-) – scottl Jun 18 '11 at 16:28
  • Then... wich are the free ones? The ones it used by default when my distro installation was finished? Anyway, I'm going to give you the bounty as there doesn't really seem to be a working solution for this problem, and you seem to have correctly identified the problem. – RobinJ Jun 19 '11 at 8:45
  • Yes, the drivers installed by default are the free nouveau drivers. Nvidia doesn't support open-source software, so nouveau doesn't have the 3D performance that the proprietary driver offers. A recent performance comparison between the two drivers is here: phoronix.com/scan.php?page=article&item=nouveau_linux3 – scottl Jun 19 '11 at 9:40

I am using Mint18.6, and the DAW reaper , and some of the UI of the plugins dont show correctly , with wine1.6, it appears to be ok in eOS with wine-rt2.0.1. Installing wine-rt 2:2.0.1 in Mint Mate 18.3 solved the problem.


What version of Java are you using (specifically, is it the latest)? If you're using openJDK, have you tried using Sun Java (and purging OJDK)? I can't speak for AbiWord, and your "Wine programs" is too vague, but I know LO/OO.o runs on Java, and Java issues sometimes manifest as UI issues. Since Java isn't dependent on the OS, it could explain why your issue persists through distros.

  • $ apt version sun-java6-jre: 6.24-1build0.10.10.1| $ apt version openjdk-6-jre: 6b20-1.9.7-0ubuntu1 – RobinJ Jun 13 '11 at 15:57
  • Try purging one of them. It's possible that having both installed is causing conflicts. (Since OpenJDK usually is installed by itself in Ubuntu, I'd go with purging it and trying Sun Java alone.) – Shauna Jun 13 '11 at 19:04
  • Urk... You gotta be kididng me xD It seems to be solved. I'll see if it's really solved by using the programs for a (few) day(s), and then I'll award the bounty. Anyway, I installed OpenJDK for running Java games, as Sun Java seems to be a disaster. Do you happen to know a solution for that as well? Is there some kind of way to choose wich version of Java should be used for LibreOffice, ...? The strange thing is that as far as I know, Wine and AbiWord don't use Java :p – RobinJ Jun 14 '11 at 17:57
  • Nope, it's not solved. As sometimes happens, it takes a while before the trouble starts. – RobinJ Jun 14 '11 at 18:04
  • Wine itself doesn't use Java that I know of, but whether an application does depends on the application. Saying that Wine does or doesn't use Java is kind of like saying Wine does or does not use DirectX (vs OpenGL). Wine technically doesn't use either of them, but the applications that run under Wine might. – Shauna Jun 14 '11 at 18:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.