2

This question already has an answer here:

I have a warning triangle on the top of my screen. When I click on it, it says that my update information is outdated. When I type sudo apt-get update && sudo apt-get upgrade into a terminal, I get this message:

W: Failed to fetch cdrom://Ubuntu 14.04 LTS _Trusty Tahr_ - Release i386 (20140417)/dists/trusty/main/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

W: Failed to fetch cdrom://Ubuntu 14.04 LTS _Trusty Tahr_ - Release i386 (20140417)/dists/trusty/restricted/binary-i386/Packages  Please use apt-cdrom to make this CD-ROM recognized by APT. apt-get update cannot be used to add new CD-ROMs

E: Some index files failed to download. They have been ignored, or old ones used instead.

Any ideas?

marked as duplicate by bain, Alaa Ali, Luis Alvarado Aug 4 '14 at 22:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • do you have the cd-rom enabled in your software&Updates options? – Virusboy Jun 7 '14 at 22:23
  • How can I check? – user285603 Jun 8 '14 at 5:02
  • System settings then Software&updates. First tab box on bottem has CDROM – Virusboy Jun 8 '14 at 5:50
  • Yeah, there are three boxes that say "Cdrom with Ubuntu 14.04 'Trusty Tahr'", and they are all checked. – user285603 Jun 8 '14 at 6:13
  • ok uncheck them all – Virusboy Jun 8 '14 at 14:57
5

Your update settings have your cdrom files enabled. So every time it tries and updates it automatically looks for those files, which by definition are outdated. Just unselect those cdrom option and sudo apt-get update && sudo apt-get upgrade should run normally.

Without cdrom install files selected.

Not the answer you're looking for? Browse other questions tagged or ask your own question.