10

I just upgraded from 12.04 to 14.04 and i kept getting stuck at the splash screen. I turned off quiet splash and it seems to be hanging after "Restoring resolver state..."

The only solution I've been able to find is to re-install Ubuntu, but i really do not want to have to do that!

Any ideas?

I have still not solved this issue and it is quite frustrating. Is there something I can do to give more information?

8

I was having this problem on an HP Mini netebook when shutting down the system, if I hit Ctrl+Alt+F7 I would see:

restoring resolver state...

These steps cleared the issue:

sudo vi /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT=”quiet splash acpi=force”
sudo update-grub

So basically edit the grub file to add the acpi=force at the end of GRUB_CMDLINE_LINUX_DEFAULT= command.

  • Same machine but not working – Chameleon Feb 10 '19 at 22:25
4

Okay I finally fixed it, here's what I did (I have an AMD gfx card):

1) Boot into GRUB and press E to edit the configuration for Ubuntu, add the word "text" after "quiet splash" then click Ctrl+X - this boots you into the command line.

2) Update - sudo apt-get dist-upgrade

3) Force removal of AMD drivers - /usr/share/ati/amd-uninstall.sh --force

4) Re-install drivers - sudo apt-get -f install

3

I arrived at a solution for the same problem. Go to the terminal by pressing alt+ctrl+F2 and type in the command

sudo dpkg --configure -a

and press enter. It will take a long time to process but once it is done restart your system and you will be taken to the login window...

  • What does this command do? What is -a and --configure? What does dpkg do, and why does it have to be root? – Tim Jul 28 '14 at 12:15
  • This did not work for me. – kevinzurek Aug 5 '14 at 19:36
  • This may work in some cases. On one of my servers the problem with name resolving was caused (most likely) due to interrupted upgrade procedure. So the reconfiguration of all packages resolved this (all missed actions were applied). Here is the quote from manual page for dpkg tool: "Configure a package which has been unpacked but not yet configured. If -a or --pending is given instead of package, all unpacked but unconfigured packages are configured." – sviklim Oct 22 '18 at 23:29
0
sudo dpkg --configure -a

Fixes broken packages

  • 1
    Kindly add more details to this answer, like what does it do exactly. – Parto Apr 5 '16 at 11:29
  • It looks for packages which are partly installed or have missing dependencies and removes them, so that none of your installed packages are broken – user241585 Apr 14 '16 at 10:44
0

I had the same problem with a clean install on a blank hard drive on my old iMac. Here is how I fixed it:

Reboot. Hold down shift key or repeatedly tap it while it's booting up. This will take you to the grub boot loader. Choose the second option. Select recovery mode. Choose the dpkg option to upgrade or repair packages, then when that's done continue to boot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.