4

My Firefox doesn't show text on some sites, such as Google:

screenshot

I use Firefox 29 and Ubuntu 14.04 (Trusty Tahr).

closed as off-topic by Lucio, Eric Carvalho, Vojtech Trefny, BuZZ-dEE, Radu Rădeanu Jun 10 '14 at 0:05

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Bug reports and problems specific to development version of Ubuntu should be reported on Launchpad so that developers can see, track and fix these issues." – Lucio, Vojtech Trefny, BuZZ-dEE, Radu Rădeanu
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Are you using Ambiance the default theme? – JoKeR Jun 7 '14 at 16:47
  • Yes, I am using default theme – Mohammad Mehdi Habibi Jun 7 '14 at 16:49
  • When did this start to happen? Did you try to reset your firefox profile help>troubleshooting info>reset firefox – JoKeR Jun 7 '14 at 16:51
  • 2
    go to browser settings as in edit>preferences>content>advanced and uncheck the box that allows other programs to choose the fonts for the page and use the fonts that I choose. – JoKeR Jun 7 '14 at 17:01
  • 1
    I think even better solution is to repair your system fonts, just do sudo apt-get install --reinstall --purge fontconfig fontconfig-config It helped me. – Yrogirg Oct 24 '17 at 15:58
5

We happened to provide the solution this way:

Go to browser settings as in edit>preferences>content>advanced and uncheck the box that allows other programs to choose the fonts for the page and use the fonts that I choose.

  • as an alternative one may try to repair system fonts with sudo apt-get install --reinstall --purge fontconfig fontconfig-config It solved the issue for me. – Yrogirg Oct 24 '17 at 16:02
  • 1
    This is a poor solution, as one usually wants the website to be able to choose fonts. Sometimes the fonts are symbols, and without them the webpage is ugly / unreadable / etc. – Bach Nov 19 '17 at 15:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.