I have just built a Desktop Computer and I have created a Live USB with Ubuntu 14.04.

I boot to the USB to "Try Ubuntu" and everything works fine, but the computer refuses to connect to the Network through Ethernet.

I don't have any other alternatives such as Wifi. And when I connect the same Ethernet Cable to my Laptop, it connects successfully.

The thing is that the Network Card is on my Motherboard and it is recognized by the system. The Kernel Modules are loaded and I tried to reload them. (as you will see below)

Here is some Info:

~$ lspci -nnk | grep -iA2 net
03:00.0 Ethernet Controller [0200]: Realtek Semiconductor Co. Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 06)
     Subsystem: Gigabyte Technology Co., Ltd Motherboard [1458:e000]
     Kernel driver in use: r8169

So the Kernel driver is: r8169. I reload it with:

~$ sudo modprobe -r r8169
~$ sudo modprobe r8169

But with no results... Still, no Connection...

I also tried with ethtool:

~$ ethtool eth0

And I got:

[...] Speed: 100Mb/s

Duplex: Full

Port: MII


Transeiver: internal

Auto-negotiation: on

Cannot get wake-on-lan settings: Operation not permitted

Current message level: 0x00000033 (51)

drv probe ifdown ifup

Link detected: yes [...]

When I try to ping my Routers Address, it says "Network Unreachable".

I haven't changed anything in the Network Connection Settings. It is a Live USB, so everything is on the Default Preference.

However, the system obviously recognizes the Card, which is on my Motherboard, and not an External one.

What else should I try to solve my Problem? Did anyone face anything similar?

Thanks in Advance.

  • Show output of ifconfig -a and netstat -rn – meccooll Jun 17 '14 at 16:35

These steps worked for me, but YMMV.

Keep your computer on. Leave it idle and watch the WiFi Signal icon. Keep your ethernet cable connected.

Reboot your router by unplugging it, waiting 30 seconds, and plugging it back in.

  • Thanks for your answer but I tried to do so. Nothing. Probably my Motherboard is not fully supported by Ubuntu? Anyway, I found that a USB WiFi Adapter worked just fine and I won't be trying to solve this issue anymore... Thanks though! – ant0nisk Sep 12 '14 at 22:31

This was a very quick and simple solution for my particular situation.

In your router:

  1. Go to DHCP Client Table and make sure the device is not listed.
  2. If it is, DELETE it.
  3. Reboot Your Router

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.