I'm using blender 2.69, installed via software centre, and when I save my user preference through File -> User Preferences and click on "Save User Settings" there is a message

"cannot open file /home/ganez/.config/blender/2.69/config/userpref.blend@ for writing permission denied"

I have checked to the path /home/ganez/.config/blender/2.69/config/ and there is no userpref.blend file present.

PS: I think this has something to do with file permission for that config folder and I have no idea on how to use the chmod command. So any advise?

Thank you in advance.

enter image description here


I just ran into the same bug. I suspect it may have occurred during a recent crash, but I cannot confirm this.

You may try to rename the folder (close Blender first):

mv ~/.config/blender ~/.config/blender.old

Then open Blender. When I tried this, Blender regenerated the folder with the proper permissions.

Generally, it is recommended to avoid running programs as root. With such a large code-base, a program is bound to have some areas of undefined behavior (bugs) that even if not malicious, could be dangerous to your system.

| improve this answer | |
  • Thank you @snapfractalpop. It worked. And +1 for the recommended way. That's what I wanted. – ganezdragon Jan 30 '15 at 17:50

OK now. I just figured it out myself for now(Answering my own question).

We have to run the program as root from the terminal.

gksudo blender

and then there won't be any problem as permission denied.

| improve this answer | |
  • I just checked my directory at ~/.config/blender/2.69/config/ and there is a file called userpref.blend in that directory, which I can open from Files application with Blender as a normal user. So my question to you is, now that you have opened Blender as root user, do you still not have the userpref.blend file in ~/.config/blender/2.69/config/? – karel Jun 28 '14 at 8:45
  • No there is still no userpref.blend file there. All I have in the directory is bookmarks.txt and recent-files.txt. I'm using blender 2.69 installed via Software Centre. – ganezdragon Jun 29 '14 at 16:34

A solution is to use chown command to take ownership of the interested folder. From terminal: navigate to the ~/.config/blender folder; check current permissions with dir -ls. For example, in my case, the folder for blender 2.72 was owned by root. So I fixed with:

sudo chown -R myusername:myusergroup /2.72

Where myusername and myusergroup are my actual Linux user name and group.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.