0

I am using Dell Alienware M14X. I have installed Ubuntu 14.04 on my laptop. The problem that I am facing is that the audio plays only through speakers all the time even I though I plug in my headphone.

When I go to sound settings, it is showing me headphones in the "play sound through" which means that my system is able to detect the headphones; But just the audio doesn't play through the headphones, instead it still plays through speaker.

1

Run the following command into the Terminal:

gksudo gedit /etc/modprobe.d/alsa-base.conf

Scroll down and add these lines to the end of the file:

#Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=dell-m6-amic

Then, save , reboot and test sound using headphones and speakers.

  • 2
    Hi Tharindu. I did whatever you have said but with no luck. Thanks for your reply though. – JItendra Jun 7 '14 at 5:19
  • Okay, then go back to the previous method and remove the lines added by you, and press Alt+Ctrl+T to open up the terminal and type alsamixer and hit Enter. You'll be greeted with a semi-UI that looks much like a mixer (imagine that!). Chances are, you will see a muted channel somewhere in that. Use the left and right arrow keys to highlight the muted channel, and press the M key to unmute it. – Tharindu Jun 7 '14 at 5:27
  • Thanks man. HP/Speakers auto detect was off in alsamixer. I turned it on and boom!! the audio started coming through my headphones. – JItendra Jun 7 '14 at 15:30
  • I also have the Alienware. When bringing up alsamixer I enabled the HP/Speakers. But I can not change the volume from 00 – javadba Mar 12 '16 at 2:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.