Having read other posts, I believe that this may be less about samba than about update system.

Below is the log file of the failed installation of Samba. I have been trying without success to install/outstall samba so that I could install anything else ...
I cannot either install or remove samba using either update-manager or apt-get (nor indeed Software Centre).
One of the errors that I have had to correct is the presence after "removal" (failed) of /usr/share/system-config-samba directory which finally allowed itself to be deleted. That, however was then ...

I have U12.04LTS. running on release 63 because I allowed the upgrade to 64 this morning which fell over - no output to monitor - obviously even less support for my graphic chip than I am suffering already (see other posts in this forum).

According to my interpretation of the dpkg returned errors there may be some problem with the package files, but if this is the case then it is on servers 'main', 'nantes uni fr' and 'best fr' at the very least if not everywhere.

The suggestions offered at Package operation failed and elsewhere have not worked for me. This linked post suggests that a similar error is present in other packages, or that the error is in the 'update system'
I have tried ...
sudo apt-get remove samba
... autoremove
... install samba
... clean
... update
-f all of the above
In update-manager I have tried the "reload packages list" which fails to terminate because of the error.
I have tried to install and remove samba from the software centre ... :(
I am at a loss ...
I need help, please! Firstly to recover my apt-get/update-manager/Software Centre so that I can at least carry on with my continuing installation - up to communicating with home network hence need for samba - which brings me to my second requirement ... samba.

PS is the issue about "MaxReports" associated or apart?

Thanks for any and all help!!

installArchives() failed:
Preconfiguring packages ...
... snip
(Reading database ...
... snip
(Reading database ... 184858 files and directories currently installed.)
Unpacking samba (from .../samba_2%3a3.6.3-2ubuntu2.10_i386.deb) ...
dpkg-deb (subprocess): data: internal gzip read error: ': data error'
dpkg-deb: error: subprocess returned error exit status 2
dpkg: error processing /var/cache/apt/archives/samba_2%3a3.6.3-2ubuntu2.10_i386.deb (--unpack):
subprocess dpkg-deb --fsys-tarfile returned error exit status 2
No apport report written because MaxReports is reached already
Selecting previously unselected package system-config-samba.
Unpacking system-config-samba (from .../system-config-samba_1.2.63-0ubuntu5_all.deb) ...
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Processing triggers for ufw ...
Processing triggers for man-db ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Errors were encountered while processing:
Error in function:
dpkg: dependency problems prevent configuration of system-config-samba:
system-config-samba depends on samba; however:
Package samba is not installed.
dpkg: error processing system-config-samba (--configure):
dependency problems - leaving unconfigured

After failed Chromium-browser install yesterday I got an update of chromium-browser in update-manager. This errored too but following the instructions Everything (EVERYTHING!!) cleared up - have finished install of wine and samba. I cannot use Chrome due to my graphics card problem no doubt, but I shall pursue that elsewhere. Too the problem with 3.2.0-64-generic-pae has not gone away but again, elsewhere ...

2 Answers 2


Try the steps provided in this answer. It always works for me. If it fails, it would be valuable to learn why and add to it:


$ sudo apt-get autoremove
$ sudo apt-get --purge remove && sudo apt-get autoclean
$ sudo apt-get -f install
$ sudo apt-get update
$ sudo apt-get upgrade && sudo apt-get dist-upgrade
$ sudo dpkg-reconfigure -a
$ sudo dpkg --configure -a

You performed most of them. There are still a couple more that can be added. But so far the ones in the list has fixed my corrupted Ubuntu broken package problems.

  • After the failed install of chromium-browser an update for it appeared in update-manager. This in turn failed, but offered instructions which when followed made the problem go away starting with a successful install of chromium-browser, then by samba and wine. I was not expecting much joy so I did not pay enough attention to record here what was done. Sorry!
    – HarveyP
    Jun 10, 2014 at 8:33

When I executed sudo apt --fix-broken install, I didn't see this line:

debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable We have to run this: sudo fuser -v /var/cache/debconf/config.dat and you'll see something like this:

                 USER        PID ACCESS COMMAND

/var/cache/debconf/config.dat: root 5346 F.... frontend And you have to run sudo kill , where PID is the number above, in this case sudo kill 5346

Finally, run sudo apt-get install -f and then you'll be able to run sudo apt-get update

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .