0

I would like to have a Bluetooth adapter powered off at the startup, but at the same time to be able to turn it on when I need it. I have found this advice: Add rfkill block bluetooth into /etc/rc.local before exit 0 command. This delivered the desired result in Gnome (at Dell D630 with Ubuntu 14.04) and now, when I need to turn power On at Bluetooth I just open System Tools->Preferences->Bluetooth and I can Enable it in there easily.

Now I want do the same in KDE (at Dell E6410 Kubuntu 14.04). However, if I patch the file as above I am not able to turn Bluetooth On any more during the working session, the icon disappears and even error message is hanging in a proper window until cold power cycle. enter image description here and enter image description here

Nevertheless there is place to (un)tick 'Powered' in tool Configuring Bluetooth -> Configuring Bluetooth Adpaters , please see this screenshot below. enter image description here I would like not to have this ticked at the startup. How to do that? I have not found setting which specifies this in any KDE tool, that's why my question is: how to the same what untick 'powered' does but from the command line? Then I could add such a string to, say, /etc/rc.local. The direct answer I did not get yet.

Finally I got a really WORKS FOR ME thing by doing what is Maco's answer in this RICH THREAD, How can I deactivate Bluetooth on system startup?

To disable the bluetooth driver from loading on startup:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

add:

 blacklist btusb

Enabling it later should just be:

sudo modprobe btusb

OKAY, that's what I wanted to do - run it again, on the go, without reset. Unfortunately namely this method is keeping my LED Bluetooth indicator (at physical panel) is turning ON, which confuses me, whether it's powered or not?

BUT the most important question for me is - does this turns off the radio module itself? I would like to have no any radiation from the Bluetooth when it is turned off at startup by any means. If it's doable please point out by what approach.

Thanks.

  • sorry, I did it, see I edited my question. – Ruslan Gerasimov Jun 6 '14 at 13:13
  • 2
    I'm not sure why KDE can't start your bluetooth service (I'm not a KDE guy), but I would not recommend you use rc.local to stop your bluetooth at boot from running. Using your method, you're basically allowing it to start at boot, and then at the end of the boot process, stopping it again. You can keep it from starting at boot altogether with the command sudo update-rc.d bluetooth disable. – rocketman10404 Jun 6 '14 at 13:25
  • @rocketman10404 Thanks, however this command returned this: update-rc.d: warning: start runlevel arguments (none) do not match bluetooth Default-Start values (2 3 4 5) update-rc.d: warning: stop runlevel arguments (none) do not match bluetooth Default-Stop values (0 1 6) System start/stop links for /etc/init.d/bluetooth do not exist. and Bluetooth is still active. – Ruslan Gerasimov Jun 7 '14 at 6:16
  • That just means your bluetooth service is already configured not to start on boot. The line in rc.local should be unnecessary now. You could also check /etc/init for any upstart scripts that may be trying to start bluetooth on boot, but I haven't seen this setup on any default Ubuntu installs before. – rocketman10404 Jun 7 '14 at 11:36
  • @rocketman10404 actually the service starts on boot in my case although the command advised by you above gives this output (again above). Ideally would be able to see the Powered item changed (to unticked state) at the picture above after sending the command turning BT power off. But is still there. – Ruslan Gerasimov Jun 8 '14 at 5:55
-1

By any chance did you install ubuntu ( unity first) and then kde from the repo? If you did, unity has a bluetooth service that locks the device and breaks kde's bluedevil. If you want to keep both kde and unity/gnome, I recommend using blueman as your bluetooth manager while in kde, cause bluedevil will not work. If you want a proper kde desktop, I suggest install a fresh kubuntu otherwise they have some conflicts nowadays.

  • I wrote in the question that it is Kubuntu. – Ruslan Gerasimov Jun 13 '14 at 22:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.