There isn't much to say about this one: when I run Software Updater, I get the above error message. That can't be good.

Interestingly, when I click on "Settings..." and then close the settings dialogue that pops up, all of a sudden Software Updater successfully finds updates and installs them.

I thought I should bring this to the attention of the Ubuntu community.

sudo apt-get update returns the following:

W: Failed to fetch http://ppa.launchpad.net/deluge-team/ppa/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.

I have screen captures, but I don't have enough reputation points to post them.

  • What is the question? What is the output of sudo apt-get update?
    – bain
    Jun 6, 2014 at 9:49
  • @LucasW Post screen-shot of error or out-put from terminal. It seems you have mis-understanding with Software & Updates visit : wiki.ubuntu.com/SoftwareUpdates for fully information about sotware-updates.
    – Pandya
    Jun 6, 2014 at 10:02
  • bain: I edited the question to include the output of sudo apt-get update Pandya: I don't believe this is the result of a misunderstanding on my part. I have screen captures for you if you need proof of what I'm claiming, but unfortunately I can't post them at the moment because I don't have enough reputation points.
    – Lucas W
    Jun 6, 2014 at 21:07
  • @underdog012 No, this does not appear to be the same error (in the link above). It's similar but not quite what I'm experiencing. Again, I wish I could post my screen caps. How do I acquire more reputation points?
    – Lucas W
    Jun 6, 2014 at 21:54
  • @LucasW You can always upload your screen caps to an external hosting provider like imgur and link them here. A high-rep user could then embed them in your posts. Jul 7, 2014 at 15:52

1 Answer 1


You receive this error message because the deluge-team repository doesn't exist. So when the Software Updater runs it can't find the repo so it gives you this error message. I looked it up for you and indeed the repository doesn't exist for Trusty.

You can look it up here. So either you will remove the repository or you can change the distribution. I don't know how safe though is the second solution because the software that this repository gives is for older versions of Ubuntu and installing software that exists for older versions may harm the OS.

If you still though you want to give it a try please reply and I will give you a brief guide with pictures on how to make it work.

  • Thank you for the reply. But what do you make of the fact that when I click on the Software Updater's "Settings..." button, and then close the Settings dialogue, the Software Updater then finds new updates and successfully installs them?
    – Lucas W
    Jun 6, 2014 at 21:49
  • The Updater just gives you a warning for a specific repository.The fact that there are updated packages from other sources(repositories) will not stop the Updater to download them and install them.Unless you mean something else which I can't understand. :) Jun 6, 2014 at 21:52
  • yeah you appear to be misunderstanding me. I can't be any clearer without posting screen caps. Unfortunately I can't at the moment.
    – Lucas W
    Jun 6, 2014 at 21:56
  • Explain again please which part I missunderstood. Jun 6, 2014 at 22:01
  • Firstly, you're linking to some other problem that's vaguely similar, but unrelated as far as I can see, so I don't even know if we're on the same page to begin with. I've described the problem as clearly and concisely as I am able. Please re-read the second paragraph of the original question. I'm just wondering why, after reporting that I should check my internet connection (which is fine, btw), the Software Updater then successfully installs updates after I click settings and close the settings dialogue? Looks like a software bug to me. But I'm an Ubuntu noob.
    – Lucas W
    Jun 6, 2014 at 22:05

Not the answer you're looking for? Browse other questions tagged .