8

I upgraded to Ubuntu 14.04 weeks ago, that was a fresh install. And as usual installed, Unity tweak tool, some themes, Chrome, eclipse etc.

Today, while playing with Unity tweak tool, I mistakenly switched Window spread to off, and bang, no problem yet. After realizing what I did I switched it to on again and then, the title bar of all windows, the status bar (guessing it's called that), and the launcher disappeared. Now I was left with a mouse cursor and the Unity tweak tool window, without the title bar. I thought a restart is needed, but sadly no shutdown option to click on, moreover, the keyboard didn't worked, neither the hardware shutdown button. So, I pressed the reset button.

After a mundane restart, I was welcomed by the wallpaper and the mouse cursor, moving, that's it. Searched everywhere for a working solution, found some solutions in AskUbuntu itself, but they where all old and required terminal to be used, but since my keyboard isn't working, no access to the terminal. So, ofcource the question isn't a dublicate, at least, IMHO.

Also, I was working on an Android project and have got no backups, so I won't be going for a clean install, or else I will start crying watching my weeks of work being deleted, any solutions, please.

  • 1
    May god help you! – Naveen Jun 6 '14 at 8:32
  • Some, out of the world genius answered the question, and the Ctrl+alt+f2 shortcut worked! I thought keyboard is dead! While I was following the steps, don't know why he deleted the answers, and don't know why I refreshed the page. God, I want that answer back! @Naveen tagging you, help if he was you. – Abhishek Verma Jun 6 '14 at 8:39
8

Lets reset the desktop

Press Ctrl + ALT + F2 Then you will get a full screen Terminal. Login with your Username and Password.

Then execute these commands in order:

rm -r ~/.config  
rm -r ~/.compiz  
sudo restart lightdm 
  • Hah, when I first read your answer, I was about to ask for a third input device to put in the shortcut. But, surprisingly it worked, thanks. – Abhishek Verma Jun 6 '14 at 8:56
  • I just forgot you mentioned that your keyboard is working. So I deleted it :D LOL – Naveen Jun 6 '14 at 8:58
  • You mean, not working :/ – Abhishek Verma Jun 6 '14 at 9:13
  • oh yeah sorry :v – Naveen Jun 6 '14 at 9:56
2

This is how I solved my issue:

Press Ctrl + ALT + F2 Then you will get a full screen Terminal. Login with your Username and Password.

sudo apt-get update
sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install unity
sudo shutdown -r now

Reference: No Unity, No Launcher, No Dash In Ubuntu 14.04

-1

I logged on in Ubuntu as a guest and was able to see all the menus and shortcuts. I guess some wrong config file cause the symptom, so I mv all files and directories staring with '.' to a temporary directory, and rebooted the system.

Now it works. None of the other solutions worked for me.

  • 1
    this is inadvisable since it will remove all local config files including your .bashrc. Try to mv the files/directories one by one to identify the culprit and restore the others – Zanna Jan 19 '17 at 10:48
  • Not really rm the config file and Ubuntu vim work fine if lacking of .bashrc. After fix the problem, you can copy the .bashrc to the origin locaiton. – user2988194 Jan 22 '17 at 7:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.