0

Yes, I know this error has been answered and solved many times; but I think I know the reason why this is happening (my bad), I just don't know how to solve it.

I was formatting and flashing some USB with 'dd' like:

dd if=myImage.img of=/dev/sdb1 bs=1M

And everything was perfectly fine until I did a big mistake:

dd if=myImage.img of=/dev/sda bs=1M

I tried to dd my /dev/sda filesystem, I got a message like this (not exactly this, I couldn't copy it):

96452+0 records in
96452+0 records out
71383424 bytes (7.1 MB) copied, 60.664 s, 495 MB/s

So I guess it started to overwrite the stuff in /dev/sda, then it crashed and I got this:

Error

So I guess I started writing on the primary partition, and overwrite important stuff at the beginning of the filesystem. After this, I get the:

Error: unknown filesystem
grub rescue >

From which I cannot get out of. I have tried the answers of other questions but I can't get rid of it. Any ideas? If you need more info, just ask. It will be helpful!

1

I finally solved it. I followed the instructions in this link.

Basically I had to:

sudo fsck.ext4 -v /dev/sda1

After a lot of fixing (and answering 'yes') I got a final message similar to this:

/dev/sda1: ***** FILE SYSTEM WAS MODIFIED *****
/dev/sda1: 88123/761856 files (1.5% non-contiguous), 2038341/3044128 blocks

Then reboot and everything was fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.