0

This question already has an answer here:

I'm pretty new to Ubuntu. I just want to open the most common ports namely

  1. FTP (port 20 TCP/UDP)
  2. HTTP (port 80 TCP/UDP)
  3. SMTP (port 25 TCP)
  4. ETC

I've tried all the ways in iptables, ufw, and gufw.

In the end, it still remains unchanged with the same error: Connection refused.

I can't even access the home page on HTTP port: 80 from the other device.

marked as duplicate by Sylvain Pineau, Eric Carvalho, user.dz, Vojtech Trefny, Mitch Jun 7 '14 at 10:22

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    We need more information. What device are you trying to access, where does it reside, and where does the device you're using ot try and access the system that is running Uubntu reside in relation to the Ubuntu system? – Thomas Ward Jun 6 '14 at 0:56
  • As Thomas W. said we need clarification. You cannot connect from another device? Did you check on your Ubuntu machine, which ports were open (netstat)? – No Time Jun 6 '14 at 2:40
0

Thanks everyone for the opinions and suggestions. Fortunately I've solved my problem.

The problem is because, I didn't assign the policy for the incoming traffic.

  • I installed the fire starter (firewall gui)
  • Then, in fire starter GUI, I added the policy in inbound traffic with the allowed ip address : 0.0.0.0/0
  • Then, I added all the ports that I wanted to open : 20,21,22,23,25,80,443
  • After I clicked on the apply the changes button, I can connect the ports from outsides successfully.

Thanks you all, anyway.

Not the answer you're looking for? Browse other questions tagged or ask your own question.