This has happened to me 3 times now, so it is definitely something I am doing. I'm hoping someone else has seen this or knows what the problem is.

First, I installed Ubuntu 12.04 from the ubuntu-12.04.4-desktop-amd64.iso image downloaded directly from the Ubuntu website. The MD5 checksums of the install image match the MD5 sums on the website:

mbpr15:source AWT$ md5 ubuntu-12.04.4-desktop-amd64.iso 
MD5 (ubuntu-12.04.4-desktop-amd64.iso) = c7f439e864d28d9e5ca2aa885c4ec4cb

Next, I followed the steps on Google's Android Open Source Project (AOSP) to prepare your Linux system for Android builds. Specifically, the steps relevant to Linux were:

$ sudo apt-get update
$ sudo apt-get install openjdk-7-jdk

$ sudo apt-get install git gnupg flex bison gperf build-essential \
  zip curl libc6-dev libncurses5-dev:i386 x11proto-core-dev \
  libx11-dev:i386 libreadline6-dev:i386 libgl1-mesa-glx:i386 \
  libgl1-mesa-dev g++-multilib mingw32 tofrodos \
  python-markdown libxml2-utils xsltproc zlib1g-dev:i386

$ ulimit -S -n 1024

Then I do the checkout and build and everything works perfectly as long as I don't shut down. Once I do a shutdown, this thing will not boot. It gets stuck at this screen:

Ubuntu boot splashscreen

And it will sit here forever. It doesn't seem to take any input at all (Esc, Alt-F1, Ctrl-Alt-F1, etc...) and the progress indicator has stopped.

Has anyone seen this or know what's causing it to hang here? I can boot to a live CD and access my filesystem, make a backup of my files, and reinstall. But as soon as I shut down, this happens again.

  • 2
    try F2 for console info. if thats not directly showing you the error: go in grub and remove quiet and splash from the cmdline (you can find howtos how to do that on SF) Jun 5, 2014 at 13:50
  • Ok, trying that now. F2 does nothing, but I booted to the grub editor and removed the quiet and splash options. It booted to a terminal login prompt and I can log in. Strange. How do I launch the Unity desktop from command line?
    – AWT
    Jun 5, 2014 at 13:58
  • Fixed it. The solution was to edit grub as you suggested, which booted me to a terminal login. I couldn't launch Unity because I got a whole mess of errors. But I reinstalled ubuntu desktop (sudo apt-get install --reinstall ubuntu-desktop) and then startx booted me to my desktop. Subsequent reboots are ok, no hangs. Put that into an answer and I will accept it, thanks for the help.
    – AWT
    Jun 5, 2014 at 14:31

2 Answers 2


first you should check if you can change to the console output by pressing F2 or ALT-F2 (never remember which one )

If that does not work or do not show you some error you should reboot and enter the grub boot menu with pressing "Shift" while booting.

When you are in the menu you should remove the "splash" and the "quiet" entries from the kernel commandline.

This way you will get the "normal" output Ubuntu (and a lot of other distributions these days) usually hides from you.

With the error(s) you might see there you can debug your issue and fix it.

  • I have tracked the cause of this problem to running Ubuntu on a virtual machine and installing the "mesa" updates: libgl1-mesa-glx:i386 libgl1-mesa-dev. If I do not install these updates, I don't get the boot hand and I don't need to reinstall ubuntu-desktop.
    – AWT
    Feb 4, 2015 at 20:34

Thanks a lot, It worked for me, but I had other problems. so I will give you some tips:

when I waited to the Splash Screen to press Ctrl-Alt-F1, it did not work

- try pressing that all the time before Splash Screen appears 

To edit grup

$ sudo nano /etc/default/grub
-delete quiet splash in GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

When I tried to sudo apt-get install --reinstall ubuntu-desktop, I got unmet dependencies,

 -I also did $ sudo apt-get install unity   
  but I do not know, if it was part of the solution
 - upgrade and update
 $ sudo apt-get upgrade
 $ sudo apt-get update

then it reinstalls without problems, then reboot

$ sudo reboot

Now, get back to work

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .