3

I have a network printer Konica Minolta bizhub C20P. Until yesterday, I'd been able to print for the past couple of years. I had Ubuntu 10.04, I upgraded to 12.04 a couple of days ago (both 10.04 and 12.04 were 32 bits). Yesterday I did a fresh installation of 14.04 64 bits, and today I've been trying to get the printer to work. I've tried several things:

a. install a new printer through System Settings/Printers, then either 1. add a driver file kmC20Pnp.ppd which I downloaded from the Minolta download centre (which is the driver I had until yesterday, which worked for all these years), or 2. select the printer model from a list;

b. install a new printer through localhost:631 with 1. and 2. (every time I try a new thing, I uninstall the unsuccessful printer first);

c. I've also tried selecting ipp and lpd printers, the last thing I tried was type lpd://IP_address/print on the Device URI, which ended up in crashing the printer

d. also some of what's described here about the i386 architecture: Can't get my Canon LBP printer to run under Ubuntu 14.04 (I had problems before while trying to install acroread that had to do with an incompatibility between i386 and amd64, so I thought that might be the problem).

Whenever I try to print a test page or otherwise connect to the printer (like when I for instance change the ipp: address) it keeps crashing (it's a copier and printer at the same time, so when it crashes, no one can print anymore, it doesn't respond to pings, and the copier doesn't respond either).

Any insight on what's happening and how to solve it will be very appreciated.

1 Answer 1

-1

I am in the same boat here. I work for a school district that has several c754 BizHub machines. Download and read Linux Cups Driver user guide for driver version 1.6, it sheds some light on the procedures to installing the new drivers from Konica, however I run 14.04 on two computers side by side and the driver is working on the 32 bit machine and not the 64 bit just yet. I have a suggestion, maybe we should contact Konica or have the local support person come out to assist. I really think it's a glitch in the driver more that it is an issue with Ubuntu. Also I noticed the driver I downloaded is marked version 1.4. When I finally get this resolved I will post it for everyone. Just because this driver doesn't work for me, it might work for you. Also when setting up the printer, use find network printer and it will set up the correct communication parameters. Hope this helps. I work with Windows, FreeBSD, and Linux. Here is the link I used for ours.

http://onyxweb.mykonicaminolta.com/OneStopProductSupport/SearchResults?products=1675

1
  • You used many words, but I didn't really get what you wanted to say actually that really answers the question. The few points in your answer that could be interesting for others would have been better placed in a comment...
    – Byte Commander
    Jan 8, 2016 at 22:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.