15

I am having a problem trying to use Startup Disk Creator with my 8GB USB stick. The USB stick has just been formatted, but Startup Disk Creator shows that there is no free space on the drive, although I can use it just fine. I am not sure whether the problem comes from when I used the drive previously with Windows 7 USB DVD Download Tool to install Windows on another computer? When I press 'Erase Disk', it shows the message below:

org.freedesktop.DBus.Python.gi._glib.GError: Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/dbus/service.py", line 707, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/share/usb-creator/usb-creator-helper", line 239, in Format
    block.call_format_sync('dos', GLib.Variant('a{sv}', {'erase': GLib.Variant('s', '')}), None)
gi._glib.GError: GDBus.Error:org.freedesktop.UDisks2.Error.Failed: Error synchronizing after initial wipe: Timed out waiting for object
4

You can try to erase/format disk with: 1. Gparted or 2. Disk Utility

sudo apt-get install gparted

sudo apt-get install gnome-disk-utility

UPDATE: You will probably need to unmount all partition(s) in Gparted (or in Disk Utility) and then delete them all and create one. Also you can do a startup disk in Unetbootin http://unetbootin.sourceforge.net/

  • 1
    I did try gparted but I still have the same problem. Is Disk Utility ok to be installed in 14.04? Does this have anything to do with the MBR sector inside my USB drive? Thanks! – CESILICON Jun 5 '14 at 9:39
  • 1
    Yes, it is ok to install Disk Utilty in 14.04. Checked. It is called gnome-disks in there. What do you mean to do with MBR sector? It knows MBR. Well, I nevertheless don't understand why is your Startup Disk Creator experiencing problem still. You will probably need to unmount all partition(s) in Gparted (or in Disk Utility) and then delete them all and create one. Also you can do a startup disk in Unetbootin http://unetbootin.sourceforge.net/. I will add this info to the answer's update. – Ruslan Gerasimov Jun 5 '14 at 12:39
  • 5
    Hi Ruslan. Thanks a lot for your suggestion. I just tried Unetbootin and it suggested me to format the USB drive to FAT32. I did that, and then I can now use Startup Disk Creator without the problem any more. I didn't realize before that NTFS doesn't work for creating a startup drive. – CESILICON Jun 5 '14 at 14:15
  • 2
    I had the same problem and after several attempts at formatting to different partition formats can confirm that apparently Ubuntu Startup Disk Creator only takes FAT32. That should be very clear at the app's main page. – Waldir Leoncio Sep 1 '14 at 13:26
  • thank you, you answered helped me understand my issue,I gnome-disk-utility was formatting my usb, but gparted failed and left me without partition and remade the partition table on the usb and then it work. – adi Oct 18 '14 at 10:39
14

Actually, there is another way to create bootable USB drive with the "Disks" utility. All you need to do is "restore disk image" using the iso file as the source image and you're good to go.

If you need more help...

  1. Open "Disks" utility.
  2. Choose the USB drive from the side.
  3. Press the little "stop" ( ■ ) button.
  4. Delete all file systems with the minus ( - ) button (WARNING: THIS WILL DELETE ALL THE DATA ON THE USB DRIVE!).
  5. Press the "two gears" button and select "Restore Disk Image".
  6. Under "Image to restore" choose your downloaded iso file.
  7. Press "Start Restoring" and you're done.

The whole process should not take more then 10 minutes.
GOOD LUCK :)

Note: some OSs like Windows won't be able to use the USB drive until you format it again.

  • I never knew this was a possibility with the disk tool, thanks much!! – xamox Dec 10 '15 at 20:52
  • 1
    I wonder which are most common nowadays: solutions or workarounds (even good ones like this). – Rodrigo Dec 13 '15 at 17:13
  • For some reason on the Disks utility from 15.10 Wily I had to choose the "=" menu from the top right, not the double gear, because Restore… was disabled there. Arrgghh! – Gringo Suave May 25 '16 at 16:56
  • NOTE: i used the top right button in that corner, not the gear. – Lucio Sep 14 '16 at 23:10
4

I saw the same problem. Here is how I solved it:

  1. If needed, install the dosfstools

    sudo apt-get install dosfstools

  2. Find out which disk needs to be reformatted. This will show a list and one of those in the list will be the USB drive you would like to reformat. In my case it was /dev/sdb1.

    fdisk -l

  3. Reformat the USB drive with something like this (NOTE: THIS WILL DELETE ALL DATA ON THE DRIVE)

    mkdosfs -F 32 -I /dev/sdb1

Also you may have to unmount the usb drive first with the following:

 `umount /dev/sdb1'

You should now be able to return to the Startup Disk Creator and build the Ubuntu boot drive.

  • This finally worked for me after fussing with gparted, fdisk, etc. Thanks! – xamox Dec 23 '15 at 19:25
2

I'm not shure if it's helpful, but it wasted five minutes of my time, and made me install Gparted. If you use "Disk Utility", option to change the file system is not accessible via "single gear" button in upper part of the window, but via "two gears button" in the middle of the window.

"Single gear" button allows only formatting in the same file system.

1

I formatted the 2GB USB disk with the Disk Utility with the option "fill with zeros". That worked for me!

1

I got this working by creating a new MSDOS partition table, one primary partition spanning the whole disk, and a new partition formatted as FAT32.

(Without success, I also tried no partition table, a blank MSDOS partition table, and a single ext4 partition before arriving at the solution above.)

0

This is caused by a regression bug in Startup Disk Creator which has turned into CD-ROM creator. Since 16.04 they have been writing the USB stick as a iso9660 CD-ROM instead of a USB stick. See my answer here for the fix.

USB Startup Disk Creator Block Size Problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.