0

I have a ubuntu 14.04 server guest os with ubuntu 14.04 host os. My virtualbox version is 4.3.10. I mount my shared folder to /media/sf_Share in guest. I make a folder in this shared folder and make syslink to /home/ubuntu/ with the following command.

ln -sf sf_Share/test /home/ubuntu

I can create syslink but can't access to the syslink directory. Actually I want to place this syslink to openerp addon folder and make it able to read from openerp. But it doesn't work. And I make a folder in openerp addon and make syslink to /media/sf_Share/. It work but this folder can't access from host OS.

I also tried to mount the shared folder directly to my desired directory but I got only Protocol error. I tried with this command.

sudo mount -t vboxsf -o uid=1000,gid=1000 Share /home/ubuntu/Share

Already installed virtualbox guest addition in my guest os. I can't find no more solution.

Please help me.

  • 1
    Finally I got it. "ln" command need to add entire path of directory. ln -sf /media/sf_Share/test /home/ubuntu/test – Zaw Myo Htet Jun 5 '14 at 4:24
0

Guest Additions itself may have been causing an additional uninvited issue you were unaware of.

The ticket for the issue can be found here https://www.virtualbox.org/ticket/12879 and has been resolved in Guest Additions 4.3.12

Guest Additions 4.3.10 has an incorrect symlink for which the workaround is to create a new symlink:

sudo ln -s /opt/VBoxGuestAdditions-4.3.10/lib/VBoxGuestAdditions /usr/lib/VBoxGuestAdditions

Once the symlink is in place you can use the Virtualbox GUI > Settings > Shared Folders to create a shared_folder_name with read or read/write permissions and check automount if desired.

then in the Guest terminal create your mount point:

sudo mkdir /mnt/shared_folder_name

and then mount:

sudo mount -t vboxsf Share /mnt/shared_folder_name

You should then be able to navigate to /mnt/shared_folder_name and see the contents of the shared folder as anticipated.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.