35

I’m running Ubuntu 14.04 Server with a LAMP stack, Samba, and FTP, no GUI, just SSHing into the server and working on it. I’m having trouble searching down a solution to this issue, but as far as I can Google for it, it might have something to do with Samba.

no talloc stackframe at ../source3/param/loadparm.c:4864, leaking memory?? 

The warning doesn't pop up at any kind of regular intervals or in response to the same or repeated actions. It pops up between things I’m doing - changing directories, editing files, copying stuff, and it often pops up when I first log in.

Has anyone got experience fixing this issue?

3
  • When do you see that message? Do you see it on a window or what?
    – Lucio
    Jun 5, 2014 at 2:23
  • i'm running Ubuntu 14.04 server edition... no GUI... just SSHing into the server and working on it. It pops up between things i'm doing. changing directories, editing files, copying stuff.. often pops up when i first log in
    – RandomOzzy
    Jun 5, 2014 at 2:32
  • It is usually a good idea to search the internet for the error message. I did it, fount this post and at the end there were 2 possible solutions.
    – sмurf
    Jun 5, 2014 at 3:36

3 Answers 3

39

This problem is related to the samba PAM module.

There are 2 solutions.

Solution 1:

Remove it with this command:

sudo apt-get remove libpam-smbpass

Reference

Solution 2:

Fix it by updating your PAM authentication module with this command:

sudo pam-auth-update

Remove the SMB password synchronization by using Down Arrow a few times and then Space. Then Tab to select OK and Enter.

Reference

6
  • 1
    And what if I want to use SMB password synchronization?
    – Dims
    Oct 3, 2014 at 13:03
  • Then, Use of solution 2
    – Salehi
    Oct 3, 2014 at 13:44
  • 2
    What is solution #2? It is said "remove SMB password synchronization"?
    – Dims
    Oct 3, 2014 at 17:38
  • No, just update the PAM Authentication module, Google it.
    – Salehi
    Oct 9, 2014 at 18:31
  • Both “solutions”, as you call them, actually disable password synchronization. Not a great idea, really.
    – kirelagin
    Dec 11, 2014 at 9:28
5

Looks like the folks at Samba have address the bug and have it staged for the next release: https://bugzilla.samba.org/show_bug.cgi?id=8449

0

Have you tried running fsck on your partitions? That particular error for me seemed to have disappeared after running it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.