15

This question already has an answer here:

If I login on my Ubuntu 14.04, I get the following desktop:Desktop

This weird behavior appeared after I executed sudo apt-get update && sudo apt-get upgrade and restarted my computer. Don't know why though.

To my Ubuntu I have tried the following (nothing seems to work so far)

Fix any broken packages:

sudo apt-get update
sudo apt-get autoclean
sudo apt-get clean
sudo apt-get autoremove

Locate any broken packages and reinstall them:

sudo apt-get install debsums
sudo apt-get clean
sudo debsums_init
sudo debsums -cs
sudo apt-get install --reinstall $(sudo dpkg -S $(sudo debsums -c) | cut -d : -f 1 | sort -u)

Removing some compiz files:

rm -r ~/.cache/compizconfig-1
rm -r ~/.compiz

Purging of NVIDIA and installing NVIDIA-prime:

sudo apt-get install --reinstall ubuntu-desktop
sudo apt-get install unity
sudo apt-get purge nvidia* bumblebee*
sudo apt-get install nvidia-prime
sudo shutdown -r now

Compizconfig Settings Manager:

sudo apt-get install compizconfig-settings-manager

export DISPLAY=:0
ccsm

// Back to UI and enablement of Unity Plugin

Unity replace, which stopped at a while and did nothing afterwards

unity --replace

Some dconf reset

dconf reset -f /org/compiz/
unity --reset-icons &disown

Actually dconf did not work and I got this error:

error: Cannot autolaunch D-Bus without X11 $DISPLAY

Can anybody help me on that?


This is my hardware (hope it helps in any way):

  • Intel® Core™ i7-3770
  • ASUS GTX660TI-DC2-OG-2GD5 (NVIDIA driver is/was installed)
  • ASUS P8Z77-V LX
  • Corsair DIMM 8 GB DDR3-1600 Kit
  • Samsung 830series 2,5" 256 GB (Windows is installed here)
  • Seagate ST31000524AS 1 TB (3/4 are reserved for files; 1/4 is for Ubuntu (16GB swap included))

marked as duplicate by karel, Eric Carvalho, Pilot6, 2707974, RPiAwesomeness Sep 8 '15 at 16:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @karel: Niklas already tried all the answers in the linked question unsuccessfully. – David Foerster Sep 7 '15 at 20:20
  • @DavidFoerster I don't have any way of knowing for sure that Niklas has already tried all 50 answers to the question that I linked to, since Niklas didn't say that, although he did say he tried a few different things. – karel Sep 8 '15 at 0:06
15

I have had the exact same problem since yesterday as well. To fix it I had to install gnome-panel then run unity reset through unity tweak tools.

  1. Switch to a virtual terminal (Ctrl+Alt+F1), log in and run the following commands:

    sudo apt-get install gnome-panel
    sudo mv ~/.Xauthority ~/.Xauthority.backup
    
  2. Reboot and select gnome on login.

  3. Once logged in open a terminal (e. g. with Ctrl+T) and run:

    sudo apt-get install unity-tweak-tool
    unity-tweak-tool --reset-unity
    
  4. Log out and log in again using Unity this time and that fixed it for me.

  • 1
    That did not quite work out for me. How can I select gnome on login? I just saw my default login view. unity-tweak-tool --reset-unity and I get failed to commit changes to dconf: Cannot autolaunch D-Bus without X11 $DISPLAY – Niklas Jun 9 '14 at 21:56
  • 1
    I executed export DISPLAY=:0 and then unity-tweak-tool --reset-unity and got this error message back dconf-WARNING **: failed to commit changes to dconf: Error spawning command line 'dbus-launch --autolaunch=<some_uuid> --binary-syntax --close-stderror': Child process exited with code 1. – Niklas Jun 10 '14 at 11:47
  • 1
    You have to click on the little ubuntu logo next to your name at login. It will only appear after installing gnome. – jaggi Jun 18 '14 at 16:06
  • The unity-tweak-tool worked for me, thanks! – macduff May 31 '15 at 0:59
  • 1
    This isn't a duplicate answer :) – Daniel Sep 13 '15 at 17:50
8

I couldn't do this because i couldn't enter the terminal. So i do this: Enter Ctrl+Alt+F1

$ sudo apt-get install gnome-panel
$ sudo mv ~/.Xauthority ~/.Xauthority.backup

Reboot and select gnome login instead of ubuntu default before writing your password to login. once logged in open a terminal Ctrl + T

$ dconf reset -f /org/compiz/
$ setsid unity

Reboot again

After that I could enter in ubuntu default login normally

Links: Ubuntu Desktop does not load http://ubuntuhandbook.org/index.php/2014/04/reset-unity-and-compiz-settings-in-ubuntu-14-04/

  • I had to press ctrl + alt + the instead of ctrl + t – Will Nov 10 '15 at 18:09
  • This worked for me, thanks! – A-Palgy Nov 15 '16 at 10:31
2
chown -R <your user>:<your group> ~/.dbus 

from GConf Error: No D-BUS daemon running?! How to reinstall or fix?

was useful to me in case of the "Cannot autolaunch D-Bus without X11 $DISPLAY" error

  • This plus the unity-tweak-tool reset worked for me! – meawoppl Sep 23 '15 at 16:09
1

Few minutes ago had this problem. Fix this too easy)) Just check your unity unity and terminal said you some like You have not unity, install it. Do that: sudo apt-get install unity and after installing write unity again. Desktop will be laucnhed.

P.S. Sorry for my bad english))

P.P.S.If Ctrl + Alt + T doesnt work press CTRL + ALT + F1

  • The problem is not that Unity is not installed. It IS installed, and is crashing. That's why this question has not been upvoted. – jvriesem Sep 16 '16 at 17:36
0

I too had this issue. Reinstalling the NVIDIA driver fixed my problem. But first install the dkms package and then reinstall the NVIDIA driver. So no need to recompile the NVIDIA modules for the latest kernel everytime you update it.

  • How can I install the DKMS packages? – Niklas Jun 9 '14 at 21:54
  • @Niklas sudo apt-get install dkms . After installing this, you may need to restart your system for the installation to take effect. – Kenpachi Jun 10 '14 at 6:39
  • dkms packages are already installed, since I have reinstalled the NVIDIA driver a thousand times, your solution does not work on my case. – Niklas Jun 10 '14 at 11:48

Not the answer you're looking for? Browse other questions tagged or ask your own question.