6

I have JBL bluetooth speakers like this one.

  1. With Ubuntu 14.04 LTS (Gnome) I get it to pair with my pc, either with gnome-bluez or blueman, but I am unable to reproduce any sound.

  2. I stumbled upon this website here, but did not managed to get it to work. I see that I cannot change my speakers in the gnome sound menu from internal to the one unplugged (to my bluetooth speakers), but I can see another profile "unplugged" available with pavucontrol. However, when I change it to that profile, I hear no sound.

  3. The aforementioned blog post says to change the connection with the JBL Flip from headset mode to A2DP mode in blueman, but I received the following error message "the device has been added successfully, but failed to connect with ubuntu".

Does anyone know how to solve that issue?

P.S.: I see a lot of unanswered/ unresolved question to this all over the Internet, I cannot believe that Ubuntu (14.04) would not handle this speakers.

  • First link is dead. Would've been nice to know what the model was... – ardila Feb 14 '17 at 21:58
  • JBL Flip 1 Bluetooth white. – Til Hund Mar 7 '17 at 11:34
3

I too do have the same JBL flip as yours and I do face the same issue, sometimes we dont hear any sound after pairing.

I am not an expert but after hit and trial: I realized you need to click on the "bluetooth" icon on top right and choose "JBL FLIP" under scroll down and move tab to "Connection ON" and then test it by clicking on sound settings

** Short flow:

*blue-tooth icon>> JBL flip (after pairing)>> move tab to COnnection ON>> sound settings>> choose JBL flip>> Choose the mode HIGH Fidelity Playback (A2DP)>> "Test Sound"

You see a "Speaker Testing for headset" window. Test it by hitting on the left and right (Front left and Front Right). You can hear the sounds on the JBL speaker.*

Note: Sometimes when you play Videos through VLC player and if you pause it for a short-while to take a break like say ten minintes. When you come back and hit play: you might not hear the sound on the JBL nor the computer speakers (Sometimes). I just UN-pair and pair speakers: Do the same test. It works! :)

This is just a workaround.

Same problem when you connect a headphones- it doesn’t automatically detect, you will have to manually select it by the above path(** Short flow)- instead of option JBL Flip, select wired headset/headphones.

Hope this helps.

| improve this answer | |
  • Did you find a fix for this problem? – Toshe Jan 27 '17 at 1:45
  • this doesn't work on ubuntu 18 – stiv Feb 2 at 9:05

Not the answer you're looking for? Browse other questions tagged or ask your own question.