1

I have very odd problem. First of all my setup :

  • WiFi router - mikrotik 2011uas-2hnd-in
  • Client 1 - Ubuntu 14.04 with Network controller: Intel Corporation Centrino Wireless-N 1000 [Condor Peak]
  • Client 2 - Windows 7 with Network controller: Intel Corporation Centrino Wireless-N 1000 [Condor Peak]

The problem is that windows client is linking to the router with 300Mbps and Linux client is linking with max of 150 Mbps. I'm pretty sure that router is right configured. Also tried Client 1 with windows setup and guess what... it's linking with 300Mbps. So my guess is that something wrong going on with Ubuntu. Tried the mainline kernel (3.14.5) and default 3.13.0-27-generic, still no change.

Here is some useful output from Ubuntu :

grep -iR [a-z0-9] /sys/module/iwlwifi/parameters/
/sys/module/iwlwifi/parameters/swcrypto:0
/sys/module/iwlwifi/parameters/power_save:N
/sys/module/iwlwifi/parameters/led_mode:0
/sys/module/iwlwifi/parameters/amsdu_size_8K:0
/sys/module/iwlwifi/parameters/fw_restart:Y
/sys/module/iwlwifi/parameters/bt_coex_active:Y
/sys/module/iwlwifi/parameters/11n_disable:0
/sys/module/iwlwifi/parameters/antenna_coupling:0
/sys/module/iwlwifi/parameters/wd_disable:1
/sys/module/iwlwifi/parameters/power_level:0

iw list
Wiphy phy0
Band 1:
Capabilities: 0x1072
HT20/HT40
Static SM Power Save
RX Greenfield
RX HT20 SGI
RX HT40 SGI
No RX STBC
Max AMSDU length: 3839 bytes
DSSS/CCK HT40
Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
Minimum RX AMPDU time spacing: 4 usec (0x05)
HT RX MCS rate indexes supported: 0-15, 32
TX unequal modulation not supported
HT TX Max spatial streams: 1
HT TX MCS rate indexes supported may differ
Frequencies:
* 2412 MHz [1] (14.0 dBm)
* 2417 MHz [2] (14.0 dBm)
* 2422 MHz [3] (14.0 dBm)
* 2427 MHz [4] (14.0 dBm)
* 2432 MHz [5] (14.0 dBm)
* 2437 MHz [6] (14.0 dBm)
* 2442 MHz [7] (14.0 dBm)
* 2447 MHz [8] (14.0 dBm)
* 2452 MHz [9] (14.0 dBm)
* 2457 MHz [10] (14.0 dBm)
* 2462 MHz [11] (14.0 dBm)
* 2467 MHz [12] (14.0 dBm) (passive scanning, no IBSS)
* 2472 MHz [13] (14.0 dBm) (passive scanning, no IBSS)
Bitrates (non-HT):
* 1.0 Mbps
* 2.0 Mbps (short preamble supported)
* 5.5 Mbps (short preamble supported)
* 11.0 Mbps (short preamble supported)
* 6.0 Mbps
* 9.0 Mbps
* 12.0 Mbps
* 18.0 Mbps
* 24.0 Mbps
* 36.0 Mbps
* 48.0 Mbps
* 54.0 Mbps
max # scan SSIDs: 20
max scan IEs length: 195 bytes
Coverage class: 0 (up to 0m)
Supported Ciphers:
* WEP40 (00-0f-ac:1)
* WEP104 (00-0f-ac:5)
* TKIP (00-0f-ac:2)
* CCMP (00-0f-ac:4)
Available Antennas: TX 0 RX 0
Supported interface modes:
* IBSS
* managed
* monitor
software interface modes (can always be added):
* monitor
interface combinations are not supported
Supported commands:
* new_interface
* set_interface
* new_key
* new_beacon
* new_station
* new_mpath
* set_mesh_params
* set_bss
* authenticate
* associate
* deauthenticate
* disassociate
* join_ibss
* join_mesh
* set_tx_bitrate_mask
* action
* frame_wait_cancel
* set_wiphy_netns
* set_channel
* set_wds_peer
* Unknown command (84)
* Unknown command (87)
* Unknown command (85)
* Unknown command (89)
* Unknown command (92)
* Unknown command (104)
* testmode
* connect
* disconnect
Supported TX frame types:
* IBSS: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* managed: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* AP: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* AP/VLAN: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* mesh point: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* P2P-client: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* P2P-GO: 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
* Unknown mode (10): 0x00 0x10 0x20 0x30 0x40 0x50 0x60 0x70 0x80 0x90 0xa0 0xb0 0xc0 0xd0 0xe0 0xf0
Supported RX frame types:
* IBSS: 0x40 0xb0 0xc0 0xd0
* managed: 0x40 0xd0
* AP: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
* AP/VLAN: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
* mesh point: 0xb0 0xc0 0xd0
* P2P-client: 0x40 0xd0
* P2P-GO: 0x00 0x20 0x40 0xa0 0xb0 0xc0 0xd0
* Unknown mode (10): 0x40 0xd0
Device supports RSN-IBSS.
HT Capability overrides:
* MCS: ff ff ff ff ff ff ff ff ff ff
* maximum A-MSDU length
* supported channel width
* short GI for 40 MHz
* max A-MPDU length exponent
* min MPDU start spacing
Device supports TX status socket option.
Device supports HT-IBSS.

iw dev wlan0 link
Connected to d4:ca:6d:e6:18:a3 (on wlan0)
SSID: CvetyBaby
freq: 2422
RX: 113048205 bytes (122363 packets)
TX: 67479855 bytes (74096 packets)
signal: -35 dBm
tx bitrate: 150.0 MBit/s MCS 7 40Mhz short GI

bss flags: short-preamble short-slot-time
dtim period: 0
beacon int: 100

When i try to set MCS index to 15 with:

# iw dev wlan0 set bitrates mcs-2.4 15

It's showing : tx bitrate: 1MBit/s

0

"PROBLEM" IS SOLVED :

According to ARK intel website:

Intel® Centrino® Wireless-N 1000, Single Band
Specifications
- Essentials   
Status   Launched
Launch Date  Q1'11
Board Form Factor   PCIe Half Mini Card
Weight (in grams)   3.4
Operating Temperature Range     0°C to 80°C
Supported Operating Systems     Windows XP, Windows Vista, Windows 8, Windows 7,Linux
- Networking Specifications
**TX/RX Streams     1x2**
Bands   2.4GHz
Max Speed   300 Mbps
Wi-Fi CERTIFIED*    802.11bgn
Compliance  PCI, CISP, FIPS, FISMA
Integrated Bluetooth    No
System Interface Type   PCIe

Linux is showing the TX bitrate, which is = 1. And windows (dunno why) is showing the RX rate, which is = 2. Mikrotik shows bitrate of it's clients, in this case my Linux laptop :

Tx/Rx rates 240.0Mbps/150.0Mbps

So Tx for Mikrotik is Rx for my Laptop = 240 Mbps (in other words RX rate = 2). Rx for Mikrotik is Tx for my laptop (in oder words Tx rate =1).

The proove ?

iw dev wlan0 link
Connected to d4:ca:6d:e6:18:a3 (on wlan0)
SSID: CvetyBaby
freq: 2457
RX: 222010900 bytes (198422 packets)
TX: 89380272 bytes (132287 packets)
signal: -30 dBm
tx bitrate: 150.0 MBit/s MCS 7 40Mhz short GI
bss flags:    short-preamble short-slot-time
dtim period:    0
beacon int:    100

MISTERY SOLVED !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.