5

I recently installed Ubuntu 14.04 and then installed bumblebee following the instructions on Ubuntu Bumblebee wiki(where they said that primusrun is better than optirun for version=> 13.10) But when I rebooted and tried to run primusrun with any applications (except google-chrome and firefox) the following error came(and comes)

primus: fatal: Bumblebee daemon reported: error: Could not load GPU driver

and surprisingly when I check the status of my nvidia driver , it gets on after running for example

primusrun clementine

sudo cat /proc/acpi/bbswitch

gives the following

0000:01:00.0 ON

Then, in order to avoid powerloss, I have to switch it off by bbswitch

NOTE : i was able to turn it off using bbswitch only after i set Driver=nouveau in the /etc/bumblebee/bumblebee.conf file and rebooted it.

6

I had the same problem.

I solved changing some lines in file /etc/bumblebee/bumblebee.conf: (In my case I'm using the version 352 of nvidia driver, change this value by your driver version)

  1. KernelDriver=nvidia-current to KernelDriver=nvidia-352

  2. LibraryPath=/usr/lib/nvidia-current:/usr/lib32/nvidia-current to LibraryPath=/usr/lib/nvidia-352:/usr/lib32/nvidia-352

  3. XorgModulePath=/usr/lib/nvidia-current/xorg,/usr/lib/xorg/modules to XorgModulePath=/usr/lib/nvidia-352/xorg,/usr/lib/xorg/modules

After that restart the system or restart the bumblebee service with:

sudo systemctl restart bumblebeed.service

To check the service status:

sudo systemctl status bumblebeed.service

and you can check the log in /var/log/syslog file for any error.

Regards

4

new update: as I thought, changing just one line in /etc/bumblebee/bumblebee.conf actually worked out: I got everything working perfectly on updated LMDE 201403 (debian jessie based) by just adding some code to KernelDriver line. Before editing, it was like:

KernelDriver=nvidia

I just added -current to it. This is line now:

KernelDriver=nvidia-current

Now works fine with primusrun glxgears and optirun glxgears. Haven't checked with anything else, have no time currently. Hope this helped, cheers. :D

EDIT: Reason why bumblebee fails and "cannot find driver" is because of incorrect paths to nvidia driver libraries. What I do right now to make bumblebee work with any driver version I wish is changing following lines in /etc/bumblebee/bumblebee.conf file:

  1. line 22: Driver=nvidia
  2. line 55: KernelDriver=nvidia-_version_, i.e. nvidia-352
  3. lines 58, 61: these lines contain paths to nvidia libraries and xorg modules. Paths probably start with /usr/lib/nvidia, /usr/lib32/nvidia, or /usr/lib/xorg. You should replace nvidia with nvidia-_version_, i.e. /usr/lib/nvidia-352. Pay attention: each line contains 2 paths, separated by colon or by comma. You should make changes to each path (DO NOT edit path that starts with /usr/lib/xorg).

Note that if you want to use default drivers, _version_ should be current, i.e. line 52: KernelDriver=nvidia-current. I think that bumblebee comes preconfigured to use nvidia-current when package bumblebee-nvidia is installed (sudo apt-get install bumblebee-nvidia).

If done correctly, bumblebee should not report error finding drivers - this worked for me with numerous driver versions.

  • 1
    Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Eliah Kagan Sep 30 '14 at 5:26
  • 1
    This worked for me. Note that you have to "sudo systemctl restart bumblebeed" after changing the configuration files. – cxrodgers Oct 9 '16 at 22:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.