I setup an instance of Ubuntu on Amazon EC2 using an AMI that I had found. When I login to the server through SSH it says

A newer build of the Ubuntu lucid server image is available.
It is names 'release' and has a build serial '20110201.1'.

What I found online was that I should run do-release-upgrade -d to upgrade the distribution. When I ran it though it seems to try to upgrade to Maverick Meerkat. I want to upgrade to the LTS release.

Is there a way that I can upgrade my server without rebuilding it?

  • Will upgrading a server image inside EC2 wipe all the existing files in your current drive attached to that instance? – evandrix Jan 6 '13 at 17:26

Ubuntu 10.04 LTS (Lucid Lynx) is currently the most recent LTS. Based on the message you've given above, it seems that you're already running 10.04, and thus, there is no newer LTS.

Now, some other points:

  1. I've written documentation on how to upgrade kernels in 10.04 in a blog post.
  2. If you are able to upgrade your instance's kernel (as described above), then the message is a bug, and it can be ignored (bug 653220)

The fact that "Ubuntu on EC2" is different than "Plain Ubuntu Server" is mostly historic at this point. If you launch new instances based on the most recent Ubuntu images for any currently supported release other than 8.04 LTS (Hardy Heron), then you can simply sudo do-release-upgrade or "dist-upgrade" and ignore that message.

| improve this answer | |
  • I am running the latest LTS, I knew that, but the error seems to be telling me that it's running a pre-release version of 10.04. – Dave Long Jun 9 '11 at 13:18
  • Prior to "pv-grub" and EBS-root, there was absolutely no way to upgrade the kernel of a running instance. The message you are seeing is a remnant of that. It is telling you that there is a newer AMI available that you could launch. Ubuntu continues to release "refreshed" AMIs so that users launching new instances will have the newest kernel available, and less updates to apply on first boot. – smoser Jun 10 '11 at 14:11
  • I've tried to upgrade from 12.04 to 12.10.. sudo do-release-upgrade won't do the job on his own. opsworks-agent and friends will being unconfigured and not working after the update – hek2mgl Nov 18 '13 at 16:46
  • I can't seem to upgrade on EC2 from 12.04 to 14.04. There are many head-shape dents in my desk and walls. – James T Snell Jan 28 '15 at 23:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.