Macbook Pro (17-inch, Late 2011)

I've tried booting from the official Ubuntu-14.04 desktop iso, and I can get to the grub menu, however choosing either "try ubuntu" or "install ubuntu" results in a blank screen, indefinitely. One peculiar thing is that before the grub menu loads, I see the following message for about a second:

Could not open "\EFT\BOOT\fallback.efi": 14
error: file "/boot/" not found.

Does anyone know how I can troubleshoot this issue? It obviously seems to be video related, but I'm not sure what's causing it.

  • Try the boot parameter "nomodeset"? – bain Jun 4 '14 at 11:40

As Bain suggested, adding the "nomodeset" parameter solved this issue for me.

From the GRUB menu when the Ubuntu installer boots, use 'e' to edit the boot parameters. Use the arrow keys to get down to the kernel line (which will probably include things like "nosplash" or "root=...". To this line, add "nomodeset" and then you can hit Ctrl-x or F10 to continue booting with the new parameters.

This should get you to the installer environment. If this works, you can continue installing Ubuntu, but the installer isn't going to put "nomodeset" in the GRUB config on the hard drive. So, when the installer reboots, you'll need to do this again when the GRUB menu from the hard drive comes up. Then, when you get to your Ubuntu desktop, run Terminal, and from there, edit /etc/default/grub:

sudo vim /etc/default/grub

and look for the line that says:


and add "nomodeset" to that line, and then save. Then, tell GRUB to refresh it's menu file with:

sudo update-grub

Then, you should be good to go.

  • I agree this is a valid answer solving the problem, but could you add some context, like how you came up/found the solution, or what you tried before? – Volker Siegel Aug 12 '14 at 20:39
  • I didn't try anything before this. I tried booting the 14.04 installer from USB and got a blank screen (but I could hear the welcome sound being played by the desktop, so I knew it was a screen issue). I googled the problem and got here. I tried Bain's suggestion and it worked. I edited my answer to step users through the process. Thanks. – Jemenake Aug 13 '14 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.