0

I have a wired USB gamepad, and really want it to work on my new linux gaming pc I built. I've installed 'jstest-gtk' and 'xboxdrv' AND 'joystick' and they seem to be working, but no game will recognize that the controller is even there (BTW, I am talking about games with full controller support, so it isn't so much a problem with the games. Also, the gamepad DOES work, at least it has on my windows machine, and jstest-gtk recognizes it's existence)! I'm assuming that it has to be something with the way the input is located, because when I run xboxdrv (sudo xboxdrv --silent), it tells me something about it being available as dev/input/js0 or dev/input/event14. Maybe the games are looking for joystick input from another directory and thus aren't receiving anything?

Any help would be appreciated.

  • Have you configured xboxdrv yet, or just installed it? Personally, I had to create a configuration file/set of command-line parameters before it actually worked for me, and you may have to do the same. – fouric Jun 4 '14 at 2:26
  • But for games that already have controller support, would I need to configure it? I figured since they already had controller support, I wouldn't need to configure it (Plus it would be a pain) – user288179 Jun 4 '14 at 15:11
1

For all controllers but the actual Xbox 360 gamepads, you have to do some configuration with xboxdrv first. By default, xboxdrv has no idea what to do with the data that your controller is throwing at it - you have to tell it "This button maps to the A, this one maps to the X, these two axes are the X and Y of the left stick, etc.".

To do this, I recommend this excellent Steam for Linux forum post.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.