I used to use google chrome as default browser. One day I tried to use Google Cast extension to send my browser screen to chromecast, but I realized that my Chrome version was old. So I downloaded the debian package from google web site, but I ran on a dependency failure:

$ sudo dpkg -i /home/plinio/Downloads/google-chrome-stable_current_amd64.deb 
    (Reading database ... 195156 files and directories currently installed.)
    Preparing to replace google-chrome-stable 35.0.1916.114-1 (using .../google-chrome-stable_current_amd64.deb) ...
    Unpacking replacement google-chrome-stable ...
    dpkg: dependency problems prevent configuration of google-chrome-stable:
     google-chrome-stable depends on libnss3 (>= 3.14.3); however:
      Version of libnss3 on system is 3.14.1-0ckbi1.93ubuntu.
    dpkg: error processing google-chrome-stable (--install):
     dependency problems - leaving unconfigured
    Processing triggers for man-db ...
    Processing triggers for desktop-file-utils ...
    Processing triggers for bamfdaemon ...
    Rebuilding /usr/share/applications/bamf.index...
    Processing triggers for gnome-menus ...
    Errors were encountered while processing:

How to solve it? I had no success with Synaptc and Ubuntu Software Center as well.


I'm using Ubuntu 12.04 LTE


Stack Exchange Mobile App is awesome! Thanks for it I could keep asking ubuntu even without network access in my workstation :D

  • 1
    Ubuntu 12.04LTS should have libnss3 3.15.4-0ubuntu0.12.04.2 available - do you get any errors after running sudo apt-get install libnss3, and if not, does chrome install OK afterwards? – rocketman10404 Jun 3 '14 at 20:55
  • @rocketman10404 It says libnss3 is already the newest version. After that, the issue remains. – Plinio.Santos Jun 3 '14 at 20:56
  • So I entered apt-get remove libnss3. After saw outputs saying that a lot of packages were being removed, including network manager, I was wondering if that was a good idea. At least I could get chrome working. Hope I will get network back either =) So, others who are reading it, you must not remove that package. Solve it in another way. – Plinio.Santos Jun 3 '14 at 21:35
  • I agree, you should find a way to upgrade without removing libnss3. Does synaptic's sources list show anything that might explain why apt doesn't see the newer version in the official repo? Does trying sudo apt-get update first help anything? – rocketman10404 Jun 3 '14 at 21:57
  • What version of Ubuntu are you on? – saiarcot895 Jun 4 '14 at 11:23

google-chrome-stable is availeble on 3rd Party Repository: Google Chrome (For Stable).

Follow the instruction for installation:

  1. Add Key:

    wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add - 
  2. Set repository:

    sudo sh -c 'echo "deb http://dl.google.com/linux/chrome/deb/ stable main" >> /etc/apt/sources.list.d/google.list'
  3. Install package:

    sudo apt-get update 
    sudo apt-get install google-chrome-stable

Looks like you need to add the official google-chrome-stable in your Software Sources

Remove your google-chrome stable or fix with sudo apt-get -f install

Follow this: How to install Google Chrome

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.