2

I have put the folder (winshare), it has some data in it, that I need under Virtual Machine---Settings---Shared Folders---Machine Folders, and in Ubuntu I have created the directory ~/media/winshare. The guest additions have been installed and I ran the command, sudo mount -t vboxsf winshare /media/winshare , from there the command executes just fine, no errors, but when I move into ~/media/winshare the data under my windows winshare file does not show up in ubuntu. Why is this? Thanks for the help!

  • Did you add your user to the vboxsf group in Ubuntu? What is the output of ls -al ~ and ls -al ~/media/winshare and ls -al /media? Are you confusing ~/media and not /media (/media is the default mount point)? – bain Jun 4 '14 at 12:16
  • btw it might be easier for you (no manual mount required) if you go to VirtualBox Settings > Shared Folder and select "Auto-mount" yes. – bain Jun 4 '14 at 12:17
  • It is solved! It turns out I did not have the permission to view the shared files – user288145 Jun 4 '14 at 20:09
  • So the answer was adding your user to the vboxsf group? – bain Jun 4 '14 at 20:11
  • It was weird I could not see it in the GUI, but was still able to cd to it – user288145 Jun 4 '14 at 20:12
0

By default VirtualBox Shared Folders are only accessible to members of the vboxsf group. To add your user to the vboxsf group in Ubuntu do:

sudo adduser $(whoami) vboxsf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.