4

When I'm Log in the Tray bar works. After the correct login it disappear , also the unity bar doesn't appear. so I can not even start a terminal session for making changes, since it does not work the keyboard shortcut to launch it (CTRL + ALT + T). How can I restore the tray and unity bar, provided that this is the problem?

Thanks all.

4

CTRL + ALT + F1 can be used to bring up a terminal. Once you log in press those keys and type in your username and password (the password will not display, just type it in anyway). Once that is done you will have a functioning terminal. Run the command unity. Then press CTRL + ALT + F7 to return to the desktop.

If Unity is still not running then switch back to the terminal (with CTRL + ALT + F1) and see if there was an error, especially in the "Initializing" section, each of those should lines should end with "...done".

Additional Suggestions:

Try running sudo apt-get install compizconfig-settings-manager followed by export DISPLAY=0:0 followed by ccsm then switch to the desktop, if it comes up make sure that the check box next to unity is checked then go to preferences on the left and click reset to defaults. After that restart the computer and try logging in.

Commands that might work:

xhost +localhost This will add you to the xhosts, I doubt that you aren't in it but probably should try anyway.

/usr/lib/nux/unity_support_test -p Run this command to check if the computer supports unity, if it doesn't you can't run it. In that case I would click the Ubuntu logo on the login screen and select Ubuntu 2D and try that.

unity --reset

sudo rm /etc/X11/xorg.conf This will reset your X11 config file.

If all of those fail you can reinstall unity:

sudo apt-get --purge remove unity
sudo apt-get install unity
sudo services lightdm restart

This will reset all of your graphical settings:

gconftool --shutdown
sudo killall -r -I gconf
sudo killall -r -I dconf
rm -rf .compiz* .gconf* .config/dconf/ .config/compiz*

If that fails this will reinstall the graphical portion of Ubuntu.

sudo apt-get install --reinstall ubuntu-desktop

You can try the same thing with compiz:

sudo apt-get install --reinstall compiz

| improve this answer | |
  • Done. It gaves me --> "WARNING: no DISPLAY variable set, setting it to :0 " and " stop: Unknown job: unity-panel-service " and " start: Unknown job: unity-panel-service" and " compiz(core) - Info: loading plugin: core " and " compiz(core) - Info: starting plugin: core ". Those 5 lines – nen-95 Jun 3 '14 at 8:25
  • Try running /usr/lib/unity/unity-panel-service and show me what that says. – john Jun 3 '14 at 8:28
  • ( unity-panel-service: 3343): Gtk-warning **: cannot open display: – nen-95 Jun 3 '14 at 9:01
  • Try running export DISPLAY=0:0 followed by exec unity. If that doesn't work try startx, and if that doesn't work run ps -x | grep lightdm and tell me what it says. – john Jun 3 '14 at 9:22
  • Ok, the first nothing change. Whit "startx" came back the menu of the window but not the tray bar and unity. Finally the last command gave me ---> " 4052 tty1 S+ 0:00 grep --color=auto lightdm " – nen-95 Jun 3 '14 at 9:37
2

I've tried john and Erv Gunter answers, however for me what did it was this last line :

sudo apt-get purge nvidia-*
sudo apt-get install ubuntu-desktop
export DISPLAY=:0 
gsettings reset org.compiz.core:/org/compiz/profiles/unity/plugins/core/ active-plugins

source

| improve this answer | |
0

I "lost" unity too, at some point. The one and only thing that fixed the problem for me:

sudo apt-get install unity-tweak-tool
unity-tweak-tool --reset

Afterwards reboot your system. After the next login, unity should be fully working again.

(I am not 100% sure if the argument is really named --reset; if that doesnt work; -help should tell you the option you need)

Disclaimer: of course this will reset all config changes you made to unity (launcher width, elements in there). But again: it once worked for me, when all the other "askubuntu" answers you can find did not.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.