I have paired my Bluetooth headset with my Ubuntu 12.04 laptop with a Bluetooth chip inside:

lsusb | grep Bluetooth

Bus 003 Device 003: ID 045e:0745 Microsoft Corp. Nano Transceiver v1.0 for Bluetooth

The device has been paired, and with the help of blueman, I've connected it to PulseAudio as a sink. Audio does come across in A2DP mode, but is terribly choppy and skips to the point of being not much better than nothing.

I read around and saw that there was a fix involving adjusting the nice priority of the PulseAudio server. Since by default, PulseAudio runs on a per-user basis, I added the following to my /etc/security/limits.conf:

*       hard    rtpio   0
*       soft    rtpio   0
@audio  hard    rtpio   20
@audio  soft    rtpio   20
pulse   hard    rtpio   20
pulse   soft    rtpio   20

I then added myself to the audio group to be able to schedule priority for the pulseaudio process. It seems that pulseaudio is now running with a priority of -11:

ps -eo pri,ni,cmd | grep [p]ulse

30 -11 /usr/bin/pulseaudio --start --log-target=syslog

This should mean that PulseAudio is running with a priority of -11, which is good.

However, even after restarting, I still get the terrible choppy audio.

How should I proceed? I'm trying to make this Bluetooth headset I purchased usable.

Note: I've tried pairing this device with an Android tablet right next to my laptop and it works fine, so it's not wireless congestion, it seems to be directly correlated to Linux somehow.


Edit the ALSA configuration file

sudo gedit /etc/modprobe.d/alsa-base.conf

Add the line

options snd-hda-intel model=generic

to the end of the file, and reboot.

  • This worked wonderfully for my BOSE quiet comfort 35 II speakers (ubuntu 18.04) – Victor Parmar Jun 26 '18 at 12:39
  • This simple fix also worked for me after a lot of searching. Ubuntu 18.10, bluetooth earphones (promate trueBlue). – Francesco Napolitano Nov 20 '18 at 14:15
  • Created an account to mention that this solved my problems too (QC35II). An explanation would be helpful; but either way, you are a life saver – Sam Jan 3 at 10:34
  • I see about 95% less choppiness with this fix with QC35II on Debian 9 testing, kernel 4.18.20-2. – Andrey Portnoy Jan 5 at 7:52
  • 2
    at the end after editing this file you don't need to restart, just run sudo service bluetooth restart – Dinuka Salwathura Jan 13 at 3:49

Had the same issue with Ubuntu 18.04 running as dual boot in MacBook Mini. Tried changing the ALSA configuration as mentioned by @ConfirmAndCreateThisAccount.

But it didn't work.

So i installed Blueman using the below command

sudo apt-get install blueman

Then i disconnected the bluetooth device from the system bluetooth settings & re-paired using Blueman. Now everything is fine. Even the Play/Pause controls work.


The fix worked for me, although I did find that I had to REM the line before it. See below:

# Keep snd-usb-audio from beeing loaded as first soundcard  
# options snd-usb-audio index=-2  <-REM this line if it doesn't work at first  
options snd-hda-intel model=generic

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.