11

I'm using Intel HD Graphics as graphics card and I'm trying to open an OpenGL program, but, when I try to run it, I have the following error: OpenGL GLX extension not supported by display ':0.0'

Then, I tried to run glxinfo, then I had the:

Error: couldn't find RGB GLX visual or fbconfig ubuntu 12.04 error.

How can I fix this error from not happening again?

4
  • this seems to be a bug bugs.launchpad.net/ubuntu/+source/mesa/+bug/1278168
    – JoKeR
    Jun 3 '14 at 3:37
  • i've already uninstalled Xserver-Xorg, but I'm still with the problem.
    – romaolucas
    Jun 4 '14 at 3:01
  • now it's working, when i reinstalled Xserver-xorg, i forgot to reboot my computer, thanks for your help!
    – romaolucas
    Jun 4 '14 at 10:33
  • 1
    could you provide your answer please with complete workaround what did you do, so that your answer might help future readers.
    – JoKeR
    Jun 4 '14 at 17:55
7

To solve my problem I had to enter the following commands:

sudo apt-get remove --purge xserver-xorg

sudo apt-get install xserver-xorg

sudo dpkg-reconfigure xserver-xorg

And then: sudo reboot

But I think that if you on pure text mode, you don't need to reboot your computer, but you would have to do sudo /etc/init.d/gdm stop before you type the commands I mentioned above and, after typing then, you will have to use sudo /etc/init.d/gdm start to start the graphic interface again.

4
  • Purging also removed ubuntu-desktop, ubuntustudio-desktop and xorg package. Recording here for @snafu after reboot. Jan 7 '16 at 14:51
  • 5
    Nah, reinstalling xserver-xorg didn't help. Jan 7 '16 at 14:54
  • Didn't have to do the --purge to get it working on my Lenovo laptop with an NVIDIA GeForce 920M card. I thought this issue was connected to my graphics drivers that are not being utilised properly, but thanks to your suggestion I know that it isn't. Jul 6 '17 at 14:07
  • Didn't work for me, what worked was: sudo apt-get --reinstall install libgl1-mesa-dri and then reboot. (Problem happened after a failed proprietary AMD drivers install.)
    – Jocelyn
    Feb 14 '19 at 11:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.