6

About 10 minutes ago I set up my basic Terminal app to be semi-transparent and was really happy with the result. Now, some updates ran and the whole "Background" tab is gone from Terminal settings. Was this option removed? If yes, why? Why would anyone do that?

I'm running gnome-terminal 3.10.2 from the Gnome3 ppa.

  • Are you using Unity or Ubuntu Gnome (or another desktop)? What version of gnome-terminal are you using? gnome-terminal --version – chaskes Jun 2 '14 at 22:48
  • I use Unity. Gnome Terminal 3.10.2 Really, just yesterday there was the setting for transparency and about 10 minutes later it disappeared... Also, I have Gnome3 ppa added. May that have something to do with it? – Radovan Bezak Jun 3 '14 at 22:55
  • 1
    Just use xfce4-terminal – Vassilis Jul 3 '16 at 13:38
  • Use an alternative terminal: xfce4-terminal (like AnwarShah said) or mate-terminal, Guake (very useful), Terminator. – UniversallyUniqueID Aug 14 '16 at 5:41
  • Yes gnome did remove terminal backgrounds a while ago. – Uwe Burger Sep 4 '16 at 2:30
7

Standard versions of Ubuntu use gnome-terminal 3.6.2. The background tab was removed in version 3.7. The ppa, as you saw, provides version 3.10.

You have a couple choices:

  1. Purge the ppa, then run an update and an upgrade to restore the standard packages. The trade-off is that you will lose the other features of Gnome 3.10 that you may want.
  2. Follow the instructions at How can I make the terminal transparent? to emulate the feature in 3.10 (quoted below):

    Since version 3.7 this option has been removed from the Preferences dialogue. You can however still get the same effect by setting the _NET_WM_WINDOW_OPACITY X property, for example with the Devil's Pie or Devil's Pie II tools. E.g., set up Devil's Pie to start automatically with the session, and create the file ~/.devilspie/gnome-terminal.ds with these contents:

(if
(matches (window_name) "gnome-terminal-window-*")
(opacity 90)
)

You can also use this shell script that however only works for existing terminal windows and not automatically for newly created ones.

  • 2
    For now I set the window opacity in CCSM, but this affects the whole window (The top bar etc.) while the original setting only affected the backround of the commandline. But it is acceptable. So... if I understand it right, when they start shipping the newest version with Ubuntu, the option will get removed anyway? If that is the case, I just may stick with the Compiz setting. EDIT: That still does not answer this in my opinion unanswerable question: Why would anyone remove that setting? Transparent terminals look awesome... – Radovan Bezak Jun 4 '14 at 7:53
2

Vivid 15.04 brings back the transparency option. (It's not part of mainstream gnome-terminal, but Ubuntu applies a patch to bring it back.)

On the other hand, background image support is gone for good.

0

To make the default Ubuntu terminal background transparent, open the terminal and select Edit -> Profile Preferences -> Background tab -> click the Transparent background radio button. You can also make the background semi-transparent by moving the slider handle under Shade transparent or image background back and forth.

enter image description here

0

Steps:

  1. Install devil's Pie

    sudo apt-get install devilspie  
    
  2. create directory .devilspie in your home directory

  3. create the file teminal.ds inside the folder created above with this content:

    (if
        (is (application_name) "Terminal")
        (begin
            (opacity 90)
        )
    )
    

Change the transparency value anyvalue from 0 to 100 by changing 90.
4. Open terminal and execute the command: devilspie

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.