I'm trying to install php amqp according to this answer https://stackoverflow.com/a/9997263/2271028

but at the make command i see following:

/bin/bash /var/www/rabbitmq-c/amqp-1.4.0/libtool --mode=compile cc  -I. -I/var/www/rabbitmq-c/amqp-1.4.0 -DPHP_ATOM_INC -I/var/www/rabbitmq-c/amqp-1.4.0/include -I/var/www/rabbitmq-c/amqp-1.4.0/main -I/var/www/rabbitmq-c/amqp-1.4.0 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib  -DHAVE_CONFIG_H  -g -O2   -c /var/www/rabbitmq-c/amqp-1.4.0/amqp.c -o amqp.lo 

libtool: compile:  cc -I. -I/var/www/rabbitmq-c/amqp-1.4.0 -DPHP_ATOM_INC -I/var/www/rabbitmq-c/amqp-1.4.0/include -I/var/www/rabbitmq-c/amqp-1.4.0/main -I/var/www/rabbitmq-c/amqp-1.4.0 -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /var/www/rabbitmq-c/amqp-1.4.0/amqp.c  -fPIC -DPIC -o .libs/amqp.o

In file included from /var/www/rabbitmq-c/amqp-1.4.0/amqp.c:46:0:

/var/www/rabbitmq-c/amqp-1.4.0/php_amqp.h:303:2: error: unknown type name 'amqp_socket_t'

/var/www/rabbitmq-c/amqp-1.4.0/amqp.c: In function 'amqp_error':

/var/www/rabbitmq-c/amqp-1.4.0/amqp.c:616:4: warning: format '%s' expects argument of type 'char *', but argument 4 has type 'int' [-Wformat]

make: *** [amqp.lo] Error 1

I see that there is some trouble with make, but can not resolve this problem. Any ideas?


1 Answer 1


I just installed amqp extension on Ubuntu 14.04, had to do some tinkering though.

Most of the fixes worked from here: http://artem.aleksashkin.com/articles/article-Installing-RabbitMQ-Ubuntu-12-04-with-PHP-extension/

But this error:

make: *** [amqp.la] Error 1 

could be solved by installing:

sudo apt-get install librabbitmq-dev

I also installed librabbitmq1, not sure if that was really necessary.

Hope this works for you! :-)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .