I have installed a DHCP Server. Now I need to stop the dhcp server, but when I issue the command:

sudo service isc-dhcp-server stop

I get stop: Unknown instance. I confirm the DHCP service is running. I have not yet configured it.

How can I stop the DHCP service in my Ubuntu Server?

Here is my interface config file:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet manual

auto br0
iface br0 inet static
  address 192.168.2.100
  netmask 255.255.255.0
  network 192.168.2.0
  broadcast 192.168.2.255
  gateway 192.168.2.1
  dns-nameserver 8.8.8.8
bridge_ports eth0
bridge_stp off
bridge_fd 0
bridge_hello 2
bridge_maxwait 0

closed as off-topic by Zanna, user.dz, Anwar, Martin Schröder, amc Nov 8 '16 at 1:14

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Zanna, user.dz, Anwar, Martin Schröder, amc
If this question can be reworded to fit the rules in the help center, please edit the question.

  • @Korkel, thank you for your prompt response. but that thread is the first I tried (out of many :() but did not work. I am getting unknown instance.... – Nilanga Jun 2 '14 at 11:48
  • running "sudo /etc/init.d/isc-dhcp-server stop" give me "Since the script you are attempting to invoke has been converted to an Upstart job, you may also use the stop(8) utility, e.g. stop isc-dhcp-server" which i tried as well but not successful ... – Nilanga Jun 2 '14 at 11:50
  • 1
    OP "fixed" by uninstalling the package, so it's unclear what was causing their problem – Zanna Nov 6 '16 at 22:23
  • 4
    @Pilot6 that isn't true, they will never be removed if they have answers. Please kindly just skip them in the queue if you don't want to vote. – Zanna Nov 7 '16 at 5:42

this can happen if you started dhcpd manaully. so, if you ran "dhcpd" on root shell, the isc dhcpd process will fire up, but not via upstart control. try killing dhcpd (run ps to find process id, and then kill it). they start it via upstart

sudo start isc-dhcp-server

Ok... so the solution I found is that I have to Uninstall or rather purge the DHCP.... and it worked...... Thanks for all the support......

  • 7
    Please expand your answer detailing the steps you took to fix the issue. – Luís de Sousa Jun 5 '14 at 6:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.