3

After updating Chrome to Version Google Chrome 35.0.1916.114 on Ubuntu 14.04, Chrome does not respond to touch events anymore at a first start.

Chrome is invoked at start up via a script by calling

google-chrome http://127.0.0.1/

Touch events worked fine with Google Chrome 34, but are broken after the update. It is not just a HTML or CSS issue, as I can move the then invisible mouse cursor on Chrome system buttons as the refresh button or the url bar and no click event takes place, but according hints are shown.

If I close Chrome and restart it again, touch events will work fine, as well as on system buttons like refresh as on HTML pages.

Maybe that is not a Chrome issue, as I ran a system update via the packet manager. But chromium-browser remained at version 34 and still accepts touch events, so it is rather a Chrome 35 issue.

Setting the --touch-events=enabled flag, as suggested in Chrome + Touchscreen + Unity (14.04) or Ubuntu 14.04 multi touch screen support, does not work.

I also tried:

  1. Starting Chrome 35 automatically by startup script
  2. killing the Chrome process after 5 seconds by the same start up script
  3. restarting the Chrome process again in that start up script

in order to activate touch interaction, as it works after closing and starting Chrome manually. That automatic approach does not work either.

Can someone confirm that behavior of Chrome? Is there a solution on activating touch events in Chrome again?

Annotation: The Ubuntu task bar accepts touch events. I can start applications via icon touch without problems.

Update:

Chrome will respond to touch events, if the touch screen was touched before start of Chrome. For instance, a single touch onto the empty desktop will do while the start up script sleeps for some seconds, starting Chrome automatically afterwards. But a simple emulated mouse click by xdotool won't help.

  • I had the same issue using Google Chrome 37.0.2062.94 on Ubuntu 13.10 and this fixed it for me. Thanks! – user323968 Sep 5 '14 at 14:03
3

Browsing the Chrome command line options at http://peter.sh/experiments/chromium-command-line-switches/ I tried option --touch-devices .

xinput list

gave the touch screen's id, leading to

google-chrome --touch-devices=10

which is working fine now. Chrome is started by a script automatically and responds to touch events afterwards.

  • how do you make chrome use that every time it starts? – NullVoxPopuli Nov 5 '14 at 19:31
  • 2
    You can export your flags from ~/.profile: export CHROMIUM_USER_FLAGS="--touch-devices=10" – chx Apr 1 '15 at 23:12

protected by Community Oct 29 '14 at 15:11

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.