1

This question already has an answer here:

Though official Catalyst software 13.1 is suitable for ati radeon hd4330, it can't be installed on Ubuntu 14.04 as it can't support Xorg >= 7.6 As I need proprietary drivers for trusty, I would like to know if there is a way to bypass this limitation ? (For example by fetching driver sources)

Here are some results from the terminal :

$ Xorg -version

X.Org X Server 1.15.1
Release Date: 2014-04-13
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-37-generic x86_64 Ubuntu
Current Operating System: Linux bordeaux80 3.13.0-27-generic #50-Ubuntu SMP Thu May 15 18:06:16 UTC 2014 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.13.0-27-generic root=UUID=4015e6f7-d11a-45fd-ac9b-5b6c7ab9eaa0 ro quiet splash vt.handoff=7
Build Date: 16 April 2014  01:36:29PM
xorg-server 2:1.15.1-0ubuntu2 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.30.2
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.

$ xrandr

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
LVDS connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 353mm x 198mm
   1366x768       60.0*+
   1280x720       59.9  
   1152x768       59.8  
   1024x768       59.9  
   800x600        59.9  
   848x480        59.7  
   720x480        59.7  
   640x480        59.4  
VGA-0 disconnected (normal left inverted right x axis y axis)
HDMI-0 disconnected (normal left inverted right x axis y axis)

$ uname -rp

3.13.0-27-generic x86_64

$ glxinfo | grep OpenGL

OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD RV710
OpenGL core profile version string: 3.1 (Core Profile) Mesa 10.1.0
OpenGL core profile shading language version string: 1.40
OpenGL core profile context flags: (none)
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 10.1.0
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:

Edit : Indeed, I would like to use WebGL inside Chrome. But seems like free drivers miss functionalities. This is my chrome://gpu settings : My chrome gpu settings at pastebin

Regards

marked as duplicate by user68186, fossfreedom Jun 2 '14 at 14:17

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Unless you compile an ancient version of Xorg and use an older kernel, there is no way. What's wrong with the open source drivers though? They should have better performance than Catalyst. – mmstick Jun 2 '14 at 10:50
  • It is because I would like to use WebGL with Chrome : it seems it can't be run with free drivers, as it lacks functionalities. – loloof64 Jun 2 '14 at 11:04
  • No it will not work. If your problem is running WebGL with Chrome, why don't you ask a question about that? How To Enable WebGL In Chrome On Ubuntu? – bain Jun 2 '14 at 11:32
  • @bain As I tried this solution in the past and it was not enough, I came to think that it is the fault of free drivers. – loloof64 Jun 2 '14 at 12:11
  • You need to manually enable hardware acceleration in Chrome, follow the top answer in the link I posted above. – bain Jun 2 '14 at 12:15

Browse other questions tagged or ask your own question.